how to make kaspersky as router

hello .. i have internet access by 3G modem  and its attached to a computer (let's call it the main computer ) and shared "iCS" to a network .. of two pcs .. " the total pcs is 3"  and each pc i have kaspersky 7 internet security
and i need to access this network from the out side i meant over internet
so i installed dynamic dns client from the dydns site on one of the computers and and this program can give me a hostname over internet and linking to my ip address
so when i try to open remote desktop from out side this network ( and of course i disabled the windows xp firewall and the stealth mode on kaspersky) it allows me to open the main computer
so what i want is to find somewhere in kaspersky internet securty 7  .. or ( if there's not such a solution in kasper) tell me to install any software can make me choose the external port and the local port and the private address in my network to access any computer in the network not just the main one .. and how can i still protected from hackers ( i meant not to make ports opened in stupid way)
sakkoraAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

skca54Senior EngineerCommented:
You may be best using an application lije 'LogMeIn'.
0
skca54Senior EngineerCommented:
Kapersky cannot function as a router. You would need hardware for this. You can get routers that will allow your 3G card to connect.
0
lance_corporal_jonesCommented:
In Kaspersky you need to open port 3389, Kaspersky already has a default rule for it so open Kaspersky main screen, on left hand side click on "system security", under firewall (middle of screen) click settings next to "network packets" then click on "Add", make sure allow is selected and under network service if you scroll down you can see "remote desktop", just add the rule then ok and you should be all set.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.