how to connect HP procurve Switch to Cisco OSPF network

how i can connect hp 6200yl switch to Cisco OSPF nework  
cisco configuration
router ospf 911
 router-id 10.252.18.11
 log-adjacency-changes
 passive-interface default
network 10.133.255.0 0.0.0.0 area 18

interface g2/6
ip address 10.133.255.1/30
ip ospf network brodcast

hp 6200yl configuration
ip router-id 10.133.255.2
router ospf
area 0.0.0.18
redistribute connected

vlan 255
ip address 10.133.255.2/30
untagged 1 (connected to cisco switch)
ip ospf 10.133.255.2 area 0.0.0.18

when i issue sh ip ospf neighbor  i cant see the cisco ospf switch

please help me to find one solution



 
jibuhebronAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

that1guy15Commented:
On your cisco router you have the line:

network 10.133.255.0 0.0.0.0 area 18

the mask 0.0.0.0 is stating only interfaces with the ip 10.133.255.0 will be in the OSPF area 18. Change the network command to:

network 10.133.255.1 0.0.0.0 area 18

This will allow interface G2/6 in the area.


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jibuhebronAuthor Commented:
still i can see the ospf neighbor  but so i solve  with static route
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.