Missing WebAdminModule

I had to rebuild my development computer and now I get the following error when trying to run Web Administrator in VS 2005:

Server Error in '/asp.netwebadminfiles' Application.

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load type 'System.Web.Administration.WebAdminModule'. (C:\Windows\Microsoft.NET\Framework\v2.0.50727\asp.netwebadminfiles\web.config line 9)

Source Error:

Line 7:          </membership>
Line 8:          <httpModules>
Line 9:              <add name="WebAdminModule" type="System.Web.Administration.WebAdminModule"/>
Line 10:         </httpModules>
Line 11:         <authentication mode="Windows"/>

Source File: C:\Windows\Microsoft.NET\Framework\v2.0.50727\asp.netwebadminfiles\web.config    Line: 9

I have reinstalled VS 2005 to no avail. I have been unble to find anything about this on EE and the MSDN topics did not help, either.
Who is Participating?
rkulpConnect With a Mentor Author Commented:
I solved the problem with the help of Microsoft. Some required files were missing from the 32 bit folder so we copied the ASPNetWebAdmin folder from a working 32 bit installation to the 32 bit folder on the 64 bit computer. We still don't know why they were not installed. I did not delete them.
GiftsonDJohnConnect With a Mentor Commented:

Make sure that your site is configured to run with v2.0 not with v1.1
rkulpAuthor Commented:
The ASP pages were working fine before so they were configured for 2.0. How do I check IIS and the other stuff that was reinstalled?
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

rkulpAuthor Commented:
The machine.config file shows version for all entries. I installed all the possibly relevant IIS modules that were not already installed. That did not help. I am now repairing the VS 2005 installation in hopes that will solve the problem.

Open IIS Manager. Locate your Web Application under Default Web Site. Right click and choose properties. In the property window you can see a tab named Asp.Net. Check whether you have selected .net version 2.0.
rkulpAuthor Commented:
The default web site was set for version 2.0. The problem persists. I then loaded VS 2005 onto a computer running Vista 32-bit and everything worked perfectly. There appears to be a problem related to 64-bit installation.
rkulpAuthor Commented:
I have discovered that WebAdmin works for a website but not a web application.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.