Printing to shared printer problems

Hi,

I have a customer with 2 distant offices, each connected to internet via its own ADSL dialup, and having VPN tunnel inbetween.

Office 1 has IP range 192.168.1.1/24
Office 2 has IP range 192.168.2.1/24
On each side there is D-link DFL-210 firewall/router, having permanent VPN established.

Now, all years everything worked OK, no problems, until last friday when DFL-210 in Office 1 died.
We replaced this router with the same model, and reconfigured it to match the old configuration.

Now, everything is working OK, EXCEPT main shared printer. It is printing randomly, for example:
- if user XY prints to this shared printer, sometimes it prints OK, but sometimes it prints to random printer on other location in Office 2!!!
- sometimes it prints only 1 page out of many, but sometimes it prints many copies of single page

Printer is HP LaserJet M1319F Multi Function Device, with fax. It was working normally until we replaced DFL-210.
But it is NOT NETWORK printer - it is installed locally via USB on server, and all is connected to local GigaBit SWITCH.

The only thing that is in common with replaced D-link is network GATEWAY address, which is IP address of replaced d-link DFL-210.
Any idea, if there is some IP rule or something, that needs to be present for shared printing to work?
LVL 18
Andrej PirmanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

paintcoCommented:
as you said only you replace the router so why did you change the default-gateway
0
rettif9DaleCommented:
Since the only thing that has changed is the Firewall/Router I would look there first. You said "reconfigured it to match the old configuration" Do you mean that you had saved the old configuration and that you copied it to the new DFL-210 or that you manually entered the same information? The newer DFL-210 may have a newer vrsion number and/or firmware. It may handle printing over the VPN connection differently. Have you read the documentation carefully? You may need to set up port forwarding to the print server. please refer to this article for more information;
http://www.chebucto.ns.ca/~rakerman/port-table.html#printing
Have you updated the firmware on the other DFL-210? after you have this problem solved you may want to do that.

rettif9
0
Andrej PirmanAuthor Commented:
Hi, thanx for replies.

I tried to solve the problem few days ago, but no go.

D-LINK
Actually, customer had DFL-200 before, and we have config backup in file, but as you say, this backup config does not fit to new DFL-210, so I had printed it out and manually configured new DFL-210 according to printout old config.

But how could DFL-210, which is a GATEWAY for OFFICE 1 LAN, have any influence to printing preferences of shared printer? DFL-210 is configured to have ALL ports opened in both directions inside LAN, so nothing is blocking traffic. Also, all ports are opened in both directions via VPN, so both offices have all traffic free.

At the moment, I have no idea, what to do, except to buy some light-weight network printer server.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

rettif9DaleCommented:
Labsy,
Are you trying to send print jobs across the VPN or ar e you just printing within the same office? If you're not sending across the VPN then the DFL-210 can't be the problem. Please provide a little more detailed explanation of the problem.
0
Andrej PirmanAuthor Commented:
No, not accross the VPN. Printer is in use just inside the same office, like this:
- workstation1 printing directly to USB printer (...which is also shared as "HP_finance")
- workstation2 printing to shared printer "HP_finance"
- workstation3 printing to shared printer "HP_finance"

Workstations1 to 3 are connected to GigaBit switch.
All workstations are in same subnet 192.168.1.1/24
All workstations have 192.168.1.1 as gateway (this is the newly configured DFL-210).
None of other printers have the same sharing name "HP_finance", so this shared printer is unique.

Problem:
printing from other workstations to "HP_finance" seems like print job is randomly sent to practically *any* shared printer not only within this OFFICE, but also to the distant office via VPN, so when you print something, random printer spits it out.
This was never seen before.
Also, this problem occured the same day when I brought and configured new DFL-210, so it might be somehow related, but I have no idea how.
0
rettif9DaleCommented:
Sorry for the slow response. My paying job has been keeping me busy. You have mentioned a server only once and you didn't elaborate.Is this is a workgroup or a domain? what kind of server are you talking about? A windows server or just a print server device? Does it provide DHCP, DNS, Active Directory? Is the router handling DHCP or are the IP addresses all static. Name resolution in a workgroup or a domain follows a specific group of steps for all shared resources. Here is a good explanation of the process.
http://technet.microsoft.com/en-us/library/bb727005.aspx
If you attempt to use a hosts file remember that all hosts need static IP addresses.
I also recommend you read this;
http://www.petri.co.il/whats_network_setup_wizard_in_windows_xp.htm
If you have a third party software firewall you should also carefully review the settings.
Here are some troubleshooting tips
http://support.microsoft.com/kb/318030
You didn't mention the workstation OS in use. XP home has limitations in a network environment.
Your particular error isn't addressed in these links but they should help you to establish a troubleshooting plan. Since local printers are shared in the format \\computer_name\printer_name it seems likely that name resolution is part of the problem. I actually doubt that the D-Link router is part of the problem since it doesn't provide name resolution. A couple of command line tools that are useful in a workgroup are nbtstat and arp do a command /? for a list of options. In a domain you can also use nslookup.
0
Andrej PirmanAuthor Commented:
Hi Rettif9, thank you for your response.

The office environment is in DOMAIN topology.
This particullar printer is not installed on SERVER (as I wrongfully stated before), but rather on one of workstations in the office.
All workstations have Windows XP PRO installed, and they all are in local DOMAIN.
They use DHCP from SERVER.
They use D-link DFL-210 as a gateway.

Nothing was changed on any workstation.

Everything was working OK for few years, until we changed old broken DFL-200 for new DFL-210. Ever since this change, local users have problems printing to this shared printer inside the same office. Printer job seems to go random to ANY printer inside domain, or sometimes number of copies is random.
This problem started with DFL-210 installation.

All diagnostics inside the local domain seems OK, no problems detected.
Ping is working as expected.
Nslookup too - all PTR records are as they should be.
Resolving by NetBIOS names works fine.
ARP table cleared on all workstations, and on D-link and server.
Also, DNS cache was manually cleared on all workstations with ipconfig /cleardns and on server's DNS service.
All computers werte rebooted many times.
Firewall on D-link DFL-210 allows ALL protocols from ANY local subnet to ANY local subnet.

But still problem persists.

One another weird thing was the initial problem, where printing did not work at the beginning.
We found out, that mistically printer driver on Workstation, where printer is connected to, was selected to use FAX portion of this printer, instead of PRINTER driver. How did this change - we do not know. But we selected proper driver and no0w it prints locally OK.
But from other clients still problems, as mentioned above.
0
rettif9DaleCommented:
The only service provided by a router that could conceivably affect printing on the local subnet is DHCP. I'm assuming that you are running DHCP on the server. If so then DHCP MUST be turned off on the router. If this were not the case I would expect you to see weird problems in arp, nbtstat, and nslookup requests as well as in ping attempts. So I'm going to assume that DHCP is turned off in the router. That being said, I think the router replacement is not a factor. BTW the command is ipconfig /flushdns.

The only other possible explanations that pop into my mind are printers setup on multiple workstations with the same name (even if the physical printer no longer exists), daisy chained printer shares (bad idea), or possibly, a corrupt printer driver.

Is the printer locally attached with a parallel or USB cable? Have you looked at the port settings for the printer?
The issue with printing the wrong number of pages or numerous copies of the same page also makes me suspect the driver. It might be a good time to consider blowing away the printer on all of the workstations, downloading the newest version, and then re-installing it as a local printer, sharing it, and then re-installing on the other workstations. I once supported a printer for a customer that required that about once every six months. I never did find an explanation. I was glad when that printer went to printer heaven.

rettif9
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Andrej PirmanAuthor Commented:
It was actually not the solution, but Rtiff did a great job explaining, so he deseves points.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.