lvmdriver failed to load

Hi,

I have an another test box which I want to test the new (for me) ESXi. This is an asustek P5W DH deluxe with SATA drives.

When I start the installation (with acpi=off and without it) I got the same error message:

Failed to load lvmdriver.
Failed trying to get a valid VMKernel MAC addresses: Filure. ...
Failed to inicialize LVM module: Failed to create UUID: Failure
Iniitialization for lvmdriver failed with -1.

In the bios setting I change the Configure SATA as (Standard IDE and AHCI too), but I got the same error.

Have you got any ideas how can I sole this ? (maybe can you advice a good cheap hardvare which loves VMWare? (enough the motherboard type) ) :)
Cook77Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

vmwarun - ArunCommented:
What version and build of ESXi are you trying to install ?
0
Cook77Author Commented:
The newest which I can download today... VMware ESXi 4.0
0
vmwarun - ArunCommented:
One of the primary reasons for the installation failing may be due to the reason that the Asus Board may not be in the Hardware Compatibility List provided by VMware

Whenever you are planning to do something related to VMware ESX or of that matter any product, check the HCL before leaping into the project

VMware HCL - http://www.vmware.com/resources/compatibility/search.php?action=search&deviceCategory=server&productId=1&advancedORbasic=advanced&maxDisplayRows=50&key=Asus&release[]=29&datePosted=-1&partnerId[]=-1&formFactorId[]=-1&cpuModeId[]=-1&cpuName[]=-1&chipset[]=-1&stepping=&nsockets=&ncores=&max_mem=&rorre=0

By the way, what is the primary reason of your VMware usage ? POC ?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Cook77Author Commented:
Yeah, I think you are right! I try with another box (Intel Q35 chipset) and the installation is succesfully completed. I use this box only for testing ...
0
jbrewsteCommented:
Not sure if this will solve your problem but ESXi I found this bit of information although it sounds unrelated to your issue it very well could be the problem. I have the exact same mother board and I am also getting this error. Here is what I stumbled across  looking for answers.

Unlike ESXi 3.5, 4.0 will require that a compatible network card be present in the host during the install. The IP address that the host obtains is used to generate a unique identifier for the host. Without a NIC that ESXi can use, it will stop with the error: Failed to load lvmdriver. To resolve this add a NIC like the Intel Pro/1000 GT or look at VMware's HCL or the white box HCL.
0
Cook77Author Commented:
Yeah I know the vmware is sensitive to the NIC, but I use the Intel Pro/1000 GT adapter and I got the same error ... Anyway thank you for your comment!
0
jbrewsteCommented:
I have a P5W Asus main board. I disabled the onboard nics and added a Intel Pro/1000GT card. Once I had the new nic the lvmdriver error stopped happening. From there I was able to install both Vmware ESXi 3.5 and 4.0
0
sambasivaCommented:
Hi

I think you may not  have accepted NIC card on your box. Could you check with atleast one of the NIC you are using is listed in the HCL. I think they use mac address to created unique hostid for ESX. so no supported nic, then no vmfs. But i think still your machine boots :)

Regards
0
barjammarCommented:
Hi, I am receiving the "Failed to load vmdriver" error when I am trying to install onto a Gigabyte EP45-UD3L motherboard with on-board NIC.  Is there a version of VM Ware which can run on Gigabyte MB lans?  This MB is the latest for Quad core Q8400 Intel processor 2.66GHZ. Is there a way the Gigabyte Lan Drivers can be picked up off the driver install disc?
0
barjammarCommented:
Sadly, I had to go and buy an expensive compatible Intel Ethernet card - then it all worked.  So now the motherboard LAN is totally disabled.
Ouch!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.