• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1009
  • Last Modified:

RealPlayer doesn't work when the user has non-admin privileges

I am trying to access .ram files which are hosted on the BBC.co.uk website.  For an example go to:
(select "Test" and there are links to .ram files contained).

Initially I couldn't access the .ram files as ISA rules disallowed access, but I have created an anonymous access rule (site requires anonymous access).  ISA has since been amended sucessfully and isn't blocking this access.  I can stream the media just by clicking on the .ram link, which in turn automatically starts up RealPlayer (Enterprise v6) and plays the respective sound clips.

Although my issue now is that I can only access whenever I have local admin rights to the PC I'm logged into.  Whenever I take my user account out of the local admins and just give it user rights then I start to encounter problems:
-  RealPlayer doesn't start up automatically when I click on .ram links (works with admin rights)

I am wondering there is maybe a GPO in pace which is causing this - I have run Group Policy Resultant Wizard, but cannot see any setting/policy that has caused this.  I have also tried to change some file permission settings on the PC so that the account in question has full control to c:\program files\\Real
and all associated subfolders, but this has made not difference.

Is there any other area on the PC I should provide further file permissions to such as a temp area etc?  

I can right click on the link and do a "save as" which saves the document locally ok, after which I can then manually open the file.  I can also manually open RealPlayer then use File > "open file" and then point to the URL where there .ram file is - this plays the audio file fine, however the user has requested that the file be available to be streamed i.e. one click.

Any other suggestions would be greatly appreciated.

Further info: The client is XP Pro (SP2), IE 6.0 and it's RealPlayer Enterprise 6.0.  Unfortunately I must stay with the versions here as this follows the agreed build standard with the customer.
  • 2
1 Solution
Adam LeinssSenior Desktop EngineerCommented:
Login in as the restricted user.
Then run Procmon as administrator from http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx
Start the capture
Try the disallowed action
Stop the capture
Under the result column, look for "Access Denied".  Right-click any entriy that states "Access Denied" and pick Highlight.  Now all the entries that are blocked should be colored an Aqua color.
Try opening these entries up.
Also, you can right-click on the process name of Real Player, pick include and this should limit the copious amount of results to just RealPlayer
meepmakerAuthor Commented:
Thanks Aleinss, your suggestion helped me greatly.  I also later found out that the RealPlayer layer (we use SVS layers (Symantec Virtual Desktop) had been stripped out too much (some missing reg keys I guess) for when I try a manual of the software I can now stream .ram files ok.  We just have to work on creating a better SVS RealPlayer layer now).
Adam LeinssSenior Desktop EngineerCommented:
Glad to have been of assistance!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now