• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 563
  • Last Modified:

Red hat 3.4 time is not updating

The server was setup as a NTP client, but the time would drift to over 30 seconds after about 4 minutes. So, I setup it up as a NTP server by running the following commands:

# echo -e "server\nserver\nserver" > /etc/ntp.conf
# chkconfig --level 2345 ntpd on
# service ntpd stop
# ntpdate
# service ntpd start

The time still doesn't seem to update properly.  Here are some of the findings I have found from troubleshooting:

     remote           refid                st t when poll reach   delay   offset     jitter
==============================================================================  .PPS.               1 u   36   64  377  178.135  -92121. 49284.3     2 u   38   64  377  215.764  -37174. 31538.9   .PPS.                1 u   39   64  377  189.214  -15835. 47743.9

[root@PEMLINMAILNFS ~]# tail -f /var/log/messages
May 26 08:41:36 PEMLINMAILNFS ntpd[2635]: ntpd 4.2.0a@1.1190-r Sun Aug 13 01:49:12 CDT 2006 (1)
May 26 08:41:36 PEMLINMAILNFS ntpd[2635]: precision = 59.000 usec
May 26 08:41:36 PEMLINMAILNFS ntpd[2635]: Listening on interface wildcard,
May 26 08:41:36 PEMLINMAILNFS ntpd[2635]: Listening on interface wildcard, ::#123
May 26 08:41:36 PEMLINMAILNFS ntpd[2635]: Listening on interface lo,
May 26 08:41:36 PEMLINMAILNFS ntpd[2635]: Listening on interface eth0,
May 26 08:41:36 PEMLINMAILNFS ntpd[2635]: kernel time sync status 0040
May 26 08:41:36 PEMLINMAILNFS ntpd: ntpd startup succeeded

When I ran  TCPDUMP UDP  PORT 123, I was seeing packets going back and forth and I have turned off the local firewall.

It looks like it it is communicating properly to the the time servers, it just is not changing the time. I only have basic knowledge of Linux, so could use some help.
  • 2
1 Solution
Change the Server's mainboard battery. If that battery is spent the time will drift.
rindi is correct, after replacing the CMOS battery, however, make sure that the BIOS time is matching with the time you are showing in Linux (replacing/reseating the CMOS battery will reset the system time). The catch 22 comes in when Linux has the ability to change the BIOS time, and the BIOS hands off the time configuration to the operating system at the boot process. If you are having issues contacting the network the system will not update the time, thus, make sure the time locally checks out before proceeding.

clock -w



will help you manually override the BIOS time and set it to the Linux time.

Also resetting BIOS defaults and flashing BIOS has resolved similar issues in the past for me.

Good Luck!
newgentechnologiesAuthor Commented:
Didn't mention this, but it is a Virtual machine.  So may have to do with the BIOS.
newgentechnologiesAuthor Commented:
The server was not executing CGI scripts. Resolved that problem and time sync worked.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now