Disable inspect esmtp on ASA 5505

We are having some problems with our ASA 5505 firewall sporadically dropping connections to our email server behind it. I was told that I should disable the inspect esmtp to see if that resolves the issue. Most emails are getting through but some mostly GMail emails connections are being dropped. Ok, I'm not a expert with Cisco Firewalls, but know how to get in and do some stuff. So step by step what is the command to disable esmtp and can this be done while users are on the network? If this doesn't work how do I put it back?
Who is Participating?
MikeKaneConnect With a Mentor Commented:
You can use either the GUI or the command line....

If you have access to ASDM GUI then:
Configuration --> Service Policy Rules -->  General/Global Policy --> Edit ---> Rule Actions --> Uncheck ESMTP
Click OK --> Apply --> Save

Or for the command line:
Use telnet, ssh, or via a direct console connection....   All depends on how it was setup.      Once you are connected:

(enter the enable password)
config t
no fixup protocol smtp 25
write mem

You can safely remove the fixup while users are connected....  

Markus BraunCEOCommented:
If you do it by SSH or telnet, do a show run, go all the way to the bottom, you will see this:

policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp

in config mode type: (assuming you know how to get there)

policy-map global_policy (press enter)

then type
class inspection_default (press enter)

now type

no   inspect esmtp (press enter)


write (press enter)

now the esmtp inspect is disabled
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.