• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 609
  • Last Modified:

Mksysb tape fails to clone system

I am attempting to clone an identical hardware (7208) RS6000 server.  I am using a mksysb tape that completes with an error: "boot image is too large".  

The client has only rootvg and has put everything in there.  I am going to attempt building the tape with it not packed and excluding their application/data directories.  

I have a document that is referenced by the error message that says I can boot from install media and then do a recovery.  I tried that and it failed similarly.

As the RAM disk is only 128MB, I am going to exclude any file that is larger than 64MB as well.  There are not many.  I'm afraid that a temp file may fill up the RAM disk root file system.

Anything else I should try?

Thank you.
  • 3
1 Solution
"identical" should read "with same or later microcodes"

you write >> boot from install media and then do a recovery.  I tried that and it failed similarly. <<

Are you able to boot from installation media? If yes, it should then always be possible to restore the mksysb from tape. The (possibly too large) boot image on tape is not needed for such a restore.

Once you got a running system (mksysb restored or not), please check immediately the microcode levels. It might well be that the firmware of the target system is too old.

Furthermore, before creating the mksysb tape, try to deinstall all 'devices...' filesets which are not needed. I saw systems with tons of printer drivers installed - but without a single printer used. Graphics and terminal drivers are good candidates, too.

Why on earth do you still use 5.2? And, what is a 7208? I only know the 8mm tape bearing that number.


RS/6000 was renamed pSeries 7 years ago - at the time 7208 was top-of-the-line SASD...
DataCenterNorcAuthor Commented:
Thank you for your help.  All three of the comments are thoughtful, however it turns out that we had two problems.

Problem one is the known bug.  In AIX 5.1 and 5.2, there is a bug that effect mksysb.  If the kernel is greater than 12 MB due to many drivers, the restore will fail.  The fix for this is to patch the firmware and the work around is to boot an alternate media of the same rev, but with fewer drivers.  

Problem two is caused by how my client uses their RS/6000.  It is only as one VG, rootvg.  All of their application is in there.  (Yes, they are aware NOW that best practice is to separate the OS from the application in most OS's.)  There are files in the application area that exceed 64MB and one is over 800 MB.  The RAM drive  (swapfs) created during the install is only 128 MB.  A temp file created from unpacking the mksysb tape filles the file system and breaks the process.   My fix for this was to run the mksysb command with the -e switch and the -p switch.  The -e switch causes an exclude file to be read and the application directories to be ignored.   The -p switch causes the mksysb tape to not be created 'packed'.   This succeeded.  We are now restoring the data file systems separately.  BTW...the mksysb tape took about 20 minutes to create this way instead of the usual four hours.  My client will be continuing with this.

As to your questions:

 Why are they still on 5.2?  Because have an OLD app that they are not able to upgrade.  I asked if they have plans.  They do not.  I bet you could have guessed the answer.  

Microcode: Yes, the knowledge base refers to the problem with the firmware.  However, the production system is not available for fixing this.  It is a 7x24 system.  Furthermore, when I suggested this, the client was not comfortable with changing anything on the production system.

RS/6000 and not p/Series.  I am very old skool for Unix.  I still think of the Linux volume management as OSF/1 compliant.  

7208 is the model number of the RS/6000 (it predates p/Series.)  BTW...it has a 4 mm DAT drive.  Yes, this system is venerable.  (I hate the word "old".)  That is why we are cloning the system.  I migrated this system 4 years ago from a Model 50 (talk about venerable) which is still sitting quietly in a back room.

You can install microcodes on 2nd system by creating floppies on windows PC
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now