Custom Report Viewer Report Navigation

Hi,

I have developed a custom report viewer with the help of the code
http://www.codeproject.com/KB/reporting-services/SQLRSViewer.aspx. Every thing works fine in development systems see the attachment working.jpg when i run project with local host, the campaign names specified are link to another report when clicked it will navigate to another report,. But when i ran the project with the use of iis web server see attachment not-working.jpg, image and report navigation doesn't work. I have no idea where it went wrong all our systems work on IIS7.0 and operating system windows 2008 server, can any one help me? It works well in XP Operating System.
working.jpg
not-working.jpg
sumankrishnaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sumankrishnaAuthor Commented:
When i changed applicationpools managed pipeline mode from integrated to classic mode It has worked.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
C#

From novice to tech pro — start learning today.