Error while accessing COM port from Laptop

Hello,

I connected a hardware for serial port communication to my laptop. When trying to open the port, I got error: system.unauthorizedaccessexception: Access to port COM1 denied.
Then I rebooted the laptop maybe twice and the error went. This happened for two successive days. I know there is no logic to this that when laptop is rebooted the error goes. But atleast I could continue with my work. Today on third day, now even after rebooting for more than 5 times, I still get the same error. When I connect this hardware to my desktop, it works. Or if I connect any other device on laptop's serial port it works. Any reason why I get this error?
Attached is bitmap.
Regards,
MI
Serial.bmp
vj_miAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DeathraceCommented:
hey,
this is not the right place for this post...please post in appropirate zone to get answers...
0
vj_miAuthor Commented:
Ok. .... sorry my mistake.... I forgot to mention that my code is written in vb.net 3.5.

Regards,
MI
0
DeathraceCommented:
I believe you're getting that error for you're trying to open a COM port that doesn't exist, or is registering as COM1.

a helpful post.. here..
http://www.dreamincode.net/forums/showtopic91090.htm
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
vj_miAuthor Commented:
I checked the above link but does not seem to solve my problem. Also note that COM1 is existing since last 2 times when I got the error and I re-booted my laptop it worked. So is it that some other software service is using COM1 port on my laptop? If that is the case, how can we identify which service/software is using COM1?

Regards,
MI
0
vj_miAuthor Commented:
OK .,.. I think I missed some portion of the link ..... When I re-read the link I got the solution.

Regards,
MI
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Visual Basic.NET

From novice to tech pro — start learning today.