Basic Configuration of Cisco Catalyst 3750 and ASA 5505

Hi - I have remote office which has an active line and I have been to test the line - I have been asked to take a Cisco Catalyst 3750 and ASA 5505 and a Laptop. My knowledge of Cisco is not very advanced. Can anyone tell me what do I have to do to get this going.

Regards
Adam
adam_kan2000Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bsohn417Commented:
What kind of lines?
please input more details
0
adam_kan2000Author Commented:
2MB internet line from the isp dsl i think
0
bsohn417Commented:
Is it ethernet handoff?
So you attach the Ethernet HANDOFF to ASA5505 (UNTRUST)
(TRUST will connect you SW) (ex: VLAN 10). U will will create DHCP on either SW or ASA and give default route for traffic pointing to DSL ip. you should be set.


0
Choose an Exciting Career in Cybersecurity

Help prevent cyber-threats and provide solutions to safeguard our global digital economy. Earn your MS in Cybersecurity. WGU’s MSCSIA degree program was designed in collaboration with national intelligence organizations and IT industry leaders.

adam_kan2000Author Commented:
WHAT ABT THE CONFIG ON THE 3750
0
bsohn417Commented:
this si very basic config
no DHSP on the switch, you will need to configure DHCP on ASA


In this config, SW will listen to ASA over VLAN 10 and it will pass the info to you connected pc

 service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname DC-VM-01
!
boot-start-marker
boot-end-marker
!
enable secret 5 cisco
!
no aaa new-model
system mtu routing 1500
vtp domain bristol
vtp mode transparent
ip subnet-zero
!
!

!
!
vlan internal allocation policy ascending
!
!
interface GigabitEthernet0/1
switch port acc vlan 10
des "Connection to cisco ASA 5505"
no shut
!
interface GigabitEthernet0/2
switch port acc vlan 10
des "MYPC"
no shut
!
interface range GigabitEthernet0/3 - 48
 shut
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 ip address x.x.x.x x.x.x.x
!
!
ip classless
no ip http server
!
!
control-plane
!
!
line con 0
 password cisco
line vty 0 4
 password  cisco
 login
line vty 5 15
 password cisco
 login
!

end
0
adam_kan2000Author Commented:
I will be attaching a server to the switch will be the DHCP SERVER
0
bsohn417Commented:
Thats fine
you will need to issue " IP DHCP SMART-relay" command for switch to pass the info.

All you have to do is create different VLAN
Cisco 3750 supports routing so issue "IP routing" command

So you will have vlan 10 (Firewall connection)
VLAN 20 (PC connection)
Make sure that pc port now access vlan 20

This should resove your issue.

int vlan 20
ip address 10.10.20.1 255.255.255.0
ip helper-address x.x.x.x (Serevr IP address)
no shut
0
adam_kan2000Author Commented:
Thanks for the answer
Do you do any Freelance work as well.

Thx
0
bsohn417Commented:
Yea
darsj21@gmail.com
0
adam_kan2000Author Commented:
thx
0
adam_kan2000Author Commented:
did u check ur email
0
bsohn417Commented:
Please check your email
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VPN

From novice to tech pro — start learning today.