Unable to remote into Windows Server 2003 server.

Posted on 2009-05-27
Medium Priority
Last Modified: 2013-11-21
I have a Windows 2003 Enterprise Server that I use for various tasks.

Well I came in this morning to remote into the server, and it says...

"This computer can't connect to the remote computer."

I tried pinging the server to verify it is up, and I get a response.

I tried to remote using the IP, same thing...

I tried to remote using :3389 at the end, same thing.

I opened the services.msc from my PC, and connected to the server. I see the Terminal Server service has started. I also see that the firewall is off, which is fine.

I need to find a way to remote into the Server. I can't just hold the power button down because of possible data corruption. I have no way to log into the server locally.

How can I remedy this issue?
Question by:Drakin030
  • 3
  • 2
LVL 38

Expert Comment

ID: 24483321
  1. Run Regedit and go to File|Connect Network Registry.
  2. Connect to the problem server.
  3. Browse to the key HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon on the remote machine.
  4. If the string value WinStationsDisabled is set to anything other than 0, change it to 0.
If that doesn't help you could try rebooting the machine by running shutdown -m \\<computername> -r -f -t 0

Author Comment

ID: 24484186
I looked in the registry, but that value was set to zero.

I also restarted the server, but I receive the same error.
LVL 72

Expert Comment

ID: 24484361
Did you check whether the RDP feature is enabled in System control applet?
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.


Author Comment

ID: 24484381
How can I verify that?

I mean I've always been able to remote into it before, it just so happens that this morning, the server won't let me.
LVL 72

Accepted Solution

Qlemo earned 2000 total points
ID: 24484715
Look into
 HKLM\System\CurrentControlSet\Control\Terminal Server
of the remote machine (the same way you did earlier). Check the following values:
 TSEnabled = 1
 fDenyTSConnections = 0
 fLicenseServer = 0

You could also download some remote software, like DameWare  (30 days trial), which allows for RDP and direct remote control (like pcAnywhere, VNC, Remote, aso.). For the latter it installs a service by itself. For the former, it allows to set the TSEnabled registry key when connecting.

Author Comment

ID: 24484767
fDenyTSConnections was set to 1

Changed it back, and that fixed it. Awesome find dude.


Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

A quick step-by-step overview of installing and configuring Carbonite Server Backup.
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
Hi, this video explains a free download that you can incorporate into your Access databases, or use stand-alone for contact management. Contacts -- Names, Addresses, Phone Numbers, eMail Addresses, Websites, Lists, Projects, Notes, Attachments…
Watch the video of Kernel Migrator for SharePoint, which demonstrate the process easily of migration from SharePoint to SharePoint, OneDrive for Business & Google Drive servers, Public Folder to SharePoint, File Server to SharePoint. The tool has va…

624 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question