Crystal Reports Toolbox Items Greyed out

I recently swapped computers after a hard drive crash, and am unable to get my crystal reports XI Release 2 Developers edition to play nice with Visual Studio.

When I open my web site, I get

  "Error      15      Could not load file or assembly 'CrystalDecisions.Web, Version=11.5.3700.0, Culture=neutral, PublicKeyToken=692fbea5521e1304' or one of its dependencies. The system cannot find the file specified.      R:\Web Page Development\RedTagRebuild\Default.aspx

and Error      14      Element 'crystalreportsource' is not a known element. This can occur if there is a compilation error in the Web site.      R:\Web Page Development\RedTagRebuild\Default.aspx      2225      29      R:\Web Page Development\RedTagRebuild\
            
I went into the toolbox selection and chose the crystal reports active x viewer, but it shows up greyed out.

When I open a new web site, none of the crystal report features are available there either.

Anyone have any idea how to fix this problem?

Apparently SAP has bought out Business Objects, so support is not an option from them, they dont have a clue.
phil301Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CodeCruiserCommented:
Crystal Reports itself is a poorly implemented software and so is the support.
Did you reinstall crystal reports?
0
phil301Author Commented:
Yes, I have re-installed it as well as Visual Studio.

I have issues upon issues.

 I originally bought the enterprise edition, then found out that you could only use it in .Net with the Developers edition. I upgraded to the Developers edition, and after weeks of emails with support, found out it woudl only work with Service Pack 2. Updated that, and managed to get it to work somehow.

In the Sap / Business Objects transition, they apparently lost all of the old support cases, so I cant even go back and see what was suggested before.  God only know how you put in a support ticket now.
0
CodeCruiserCommented:
Have you followed the similar steps this time such as service packs etc?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
phil301Author Commented:
Yes, I am a little confused on the order of installation ( I posted another thread about this).

I have the Original CR Enterprise Edition ( I think)
The  CRXIDev.exe Developers Upgrade file
crxir2.part.exe file
and the SP2 setup file

I started with the CRXIDev.exe file, and entered the keycode for the Developers edition ( this should take care of any licensing issue with the Enterprise edition)
I am now loading the crxir2.part.exe to get it up to Release2.
Then I am going to load the SP2 files.

Does that order sound correct?
0
phil301Author Commented:
It will remove the original installation of CRXIDEV.exe  when I run the crxir2.part.exe and upgrade it to R2
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.