Post XML file to remote server

I am attempting to use a gateway to an external interface for data exchange between my institution and an external site. Data is exchanged using XML documents defined by the third party. I am new to XML and have been able to get a 200 OK response from the external server, but the anticipated result of rates on the site changing does not occur.

Can you review the code below and point me in a direction as to where I might be going wrong?

Below is my attempt at the post code and also the xml file. I have followed the remote companies example xml file and it should be good, my main concern is with the post code.

Also, attached is their Rate Integration Guide.

Assistance would be greatly appreciated.
Dim xmlDoc
Dim xmlHTTP 
Dim ConfirmationXML
Set xmlDoc = server.CreateObject("Microsoft.XMLDOM")
xmlDoc.async = False
xmlDoc.Load "E:\file.xml"
Set xmlHTTP = server.CreateObject("WinHttp.WinHttpRequest.5.1")
xmlHTTP.Open "POST",
"https://test-interface.mortgagewebcenter.com/XML/Gateway.asp", False
xmlHTTP.send xmlDoc.xml
xmlHTTP.WaitForResponse
ConfirmationXML = xmlHTTP.Status & " " & xmlHTTP.StatusText
Set xmlDoc = Nothing
Set xmlHTTP = Nothing
response.Write(ConfirmationXML)
 
 
 
<?xml version="1.0" encoding="UTF-8"?>
<TRANSACTION Type="MR_HTTPS_01" ProcessFeedback="Error" >
<MWC_AUTHENTICATION>
<USER_CODE>######</USER_CODE>
<PASSWORD>#######</PASSWORD>
<DOMAIN_CODE>#######</DOMAIN_CODE>
</MWC_AUTHENTICATION>
<RATE_UPLOAD>
<PARTNER Partner_Id="123"/>
<RATE_DATA>
PARTNER_ID,PRODUCT_ID,STATE_ID,COUNTY_CODE,MIN_LOAN_AMOUNT,MAX_LOAN_AMOUNT,L
OCK_PERIOD_ID,RATE,POINTS,REBATE,LOCK_EXPIRATION_DATE,ARM_INDEX_VALUE,HEQ_LO
C_MARGIN,
2761,0,3,0,1000000,4.75,0,0,10/1/08,0,
19053,0,3,0,1000000,4.75,0,0,10/1/08,0,
2767,0,3,0,1000000,4.75,0,0,10/1/08,0,
2811,0,3,0,1000000,4.75,0,0,10/1/08,0,
2762,0,3,0,1000000,4.75,0,0,10/1/08,0,
2812,0,3,0,1000000,4.75,0,0,10/1/08,0,
2763,0,3,0,1000000,4.75,0,0,10/1/08,0,
2813,0,3,0,1000000,4.75,0,0,10/1/08,0,
2768,0,3,0,1000000,4.75,0,0,10/1/08,0,
2769,0,3,0,1000000,4.75,0,0,10/1/08,0,
8303,0,3,0,1000000,4.75,0,0,10/1/08,0,
8304,0,3,0,1000000,4.75,0,0,10/1/08,0,
2764,0,3,0,1000000,4.75,0,0,10/1/08,0.64,
2765,0,3,0,1000000,4.75,0,0,10/1/08,0.64,
7893,0,3,0,1000000,4.75,0,0,10/1/08,0.64,
2766,0,3,0,1000000,4.75,0,0,10/1/08,0.64,
7894,0,3,0,1000000,4.75,0,0,10/1/08,0.64,
7769,0,3,0,1000000,4.75,0,0,10/1/08,0.64,
7770,0,3,0,1000000,4.75,0,0,10/1/08,0.64,
16779,0,3,0,1000000,4.75,0,0,10/1/08,0.64,
16780,0,3,0,1000000,4.75,0,0,10/1/08,0.64,
</RATE_DATA>
</RATE_UPLOAD>
</TRANSACTION>

Open in new window

MortgagebotRateIntegrationGuide.doc
sstillisAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BigRatCommented:
You're not setting the content type. See MS Knowledge Base Q290591 Add :-

xmlhttp.setRequestHeader("Content-Type", "text/xml");


You may have to use application/xml instead of text/xml. Ask the receiver of the data.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
XML

From novice to tech pro — start learning today.