IPSEC Tunnel between PIX 6.3 and ASA 8.0 does not come up

Greetings,

We have an ASA 5505 which is terminating three tunnels. Two work, one is from a PIX 6.3 and another is from an ASA 8.0. The third tunnel does not work. I verified the preshared keyes, encryption and ISAKMP policies visually and by comparing the configuration of the two PIX firewalls. The only difference is that the functioning PIX firewall uses 3DES encryption, while the non-functioning PIX uses DES. I cannot see any issues at all.

I have been trying to get the tunnel up for a couple of days, any help would be appreciated.
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
interface ethernet1 vlan2 logical
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif vlan2 wifidmz security50
enable password WWWxxxYYYzzz encrypted
passwd AAAbbbCCCddd encrypted
hostname Jani-WappingerFalls
domain-name janitronicsinc.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list VPN_ACL permit ip 10.1.3.0 255.255.255.0 10.0.0.0 255.255.255.0 
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute
ip address inside 10.1.3.1 255.255.255.0
ip address wifidmz 172.20.20.1 255.255.255.0
ip audit name janiaudit attack action drop
ip audit interface inside janiaudit
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list VPN_ACL
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
nat (wifidmz) 1 172.20.20.0 255.255.255.0 0 0
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+ 
aaa-server TACACS+ max-failed-attempts 3 
aaa-server TACACS+ deadtime 10 
aaa-server RADIUS protocol radius 
aaa-server RADIUS max-failed-attempts 3 
aaa-server RADIUS deadtime 10 
aaa-server LOCAL protocol local 
aaa authentication ssh console LOCAL
http server enable
http 10.1.3.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set DES_MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set DES_SHA esp-des esp-sha-hmac 
crypto map VPN_MAP 10 ipsec-isakmp
crypto map VPN_MAP 10 match address VPN_ACL
crypto map VPN_MAP 10 set peer A.B.C.D
crypto map VPN_MAP 10 set transform-set DES_MD5
crypto map VPN_MAP interface outside
isakmp enable outside
isakmp key ******** address 66.109.32.2 netmask 255.255.255.255 
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 1000
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
isakmp policy 30 authentication pre-share
isakmp policy 30 encryption des
isakmp policy 30 hash md5
isakmp policy 30 group 2
isakmp policy 30 lifetime 86400
telnet 10.0.0.0 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 60
console timeout 0
dhcpd address 10.1.3.100-10.1.3.150 inside
dhcpd address 172.20.20.100-172.20.20.150 wifidmz
dhcpd dns 10.0.0.10 4.2.2.1
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd enable inside
dhcpd enable wifidmz
username AAAAbbbbCCCCdddd password WWWxxxYYYzzz encrypted privilege 15
terminal width 80
Cryptochecksum:f9d655477f7acab78385a37b25e02ed0
 
 
: Saved
:
ASA Version 8.0(2) 
!
hostname Janitronics-ASA
domain-name janitronicsinc.com
enable password WWWxxxYYYzzz encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.0.0.250 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 66.109.32.2 255.255.255.248 
!
interface Vlan10
 description Untrust guest Wireless VLAN
 no forward interface Vlan1
 nameif wireless
 security-level 50
 ip address 172.16.30.1 255.255.255.0 
!             
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
 description Trunk Workaround for Cisco WAP
 switchport access vlan 10
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd WWxxxYYYzzz encrypted
boot system disk0:/asa802-k8.bin
ftp mode passive
dns server-group DefaultDNS
 domain-name janitronicsinc.com
access-list internet extended permit tcp any host 66.109.32.3 eq www 
access-list internet extended permit tcp any host 66.109.32.3 eq smtp 
access-list internet extended permit tcp any host 66.109.32.3 eq https 
access-list internet extended permit tcp any host 66.109.32.2 eq www 
access-list internet extended permit tcp any host 66.109.32.2 eq https 
access-list internet extended permit tcp 66.195.66.32 255.255.255.240 host 66.109.32.3 eq 3389 
access-list internet extended permit tcp any host 66.109.32.2 eq pptp 
access-list VPN_ACL extended permit ip 10.0.0.0 255.255.255.0 10.1.1.0 255.255.255.0 
access-list VPN_ACL extended permit ip 10.0.0.0 255.255.255.0 10.1.2.0 255.255.255.0 
access-list VPN_ACL extended permit ip 10.0.0.0 255.255.255.0 10.1.3.0 255.255.255.0 
access-list wireless_out extended permit ip 172.16.30.0 255.255.255.0 any 
access-list wireless_out extended permit icmp 172.16.30.0 255.255.255.0 any 
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu wireless 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-602.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list VPN_ACL
nat (inside) 1 0.0.0.0 0.0.0.0
nat (wireless) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp 66.109.32.3 www A.B.C.D www netmask 255.255.255.255 
static (inside,outside) tcp 66.109.32.3 pop3 A.B.C.D pop3 netmask 255.255.255.255 
static (inside,outside) tcp 66.109.32.3 smtp A.B.C.D smtp netmask 255.255.255.255 
static (inside,outside) tcp 66.109.32.3 https A.B.C.D https netmask 255.255.255.255 
static (inside,outside) tcp 66.109.32.3 3389 A.B.C.D 3389 netmask 255.255.255.255 
static (inside,outside) tcp interface pptp A.B.C.D pptp netmask 255.255.255.255 
static (inside,outside) tcp interface https A.B.C.D https netmask 255.255.255.255 
static (inside,outside) tcp interface www A.B.C.D www netmask 255.255.255.255 
access-group internet in interface outside
access-group wireless_out in interface wireless
route outside 0.0.0.0 0.0.0.0 66.109.32.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
aaa authentication http console LOCAL 
aaa authentication ssh console LOCAL 
aaa authentication telnet console LOCAL 
aaa authentication serial console LOCAL 
http server enable
http 10.0.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set VPN_SET esp-des esp-md5-hmac 
crypto ipsec transform-set VPN_Secure esp-3des esp-md5-hmac 
crypto dynamic-map DYN_VPN_MAP 1 set transform-set VPN_Secure
crypto dynamic-map DYN_VPN_MAP 2 set transform-set VPN_SET
crypto map DYN_MAP 20 ipsec-isakmp dynamic DYN_VPN_MAP
crypto map DYN_MAP interface outside
crypto isakmp identity address 
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption des
 hash md5
 group 1
 lifetime 1000
crypto isakmp policy 20
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 30
 authentication pre-share
 encryption des
 hash md5
 group 2
 lifetime 86400
crypto isakmp policy 50
 authentication pre-share
 encryption 3des
 hash md5
 group 1
 lifetime 864000
no crypto isakmp nat-traversal
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 60
console timeout 0
management-access inside
dhcpd dns 4.2.2.1 4.2.2.2
!
dhcpd address 172.16.30.100-172.16.30.150 wireless
dhcpd enable wireless
!             
 
threat-detection basic-threat
threat-detection statistics access-list
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect pptp 
!
service-policy global_policy global
username AAAbbbCCCddd password WWWxxxYYYzzz encrypted privilege 15
tunnel-group DefaultL2LGroup ipsec-attributes
 pre-shared-key *
prompt hostname context 
Cryptochecksum:78add03c605e3d248496198cb278bbd3
: end

Open in new window

ebreissAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ebreissAuthor Commented:
A debug from the ASA shows the following:

May 27 16:10:42 [IKEv1]: Group = DefaultL2LGroup, IP = 69.118.35.6, QM FSM error (P2 struct &0xd51e2af8, mess id 0x9d4b5aae)!
May 27 16:10:42 [IKEv1]: Group = DefaultL2LGroup, IP = 69.118.35.6, Removing peer from correlator table failed, no match!
May 27 16:11:12 [IKEv1]: Group = DefaultL2LGroup, IP = 69.118.35.6, QM FSM error (P2 struct &0xd4a26180, mess id 0xa9c65110)!
May 27 16:11:12 [IKEv1]: Group = DefaultL2LGroup, IP = 69.118.35.6, Removing peer from correlator table failed, no match!
0
ebreissAuthor Commented:
I found it myself. Here is the issue:

Phase 2 authentication was failing because there was no transform set. But there IS a transform set! What I had to do was set the worst transform set to be the lowest priority on the ASA. Once I did that the tunnel came up immediately.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VPN

From novice to tech pro — start learning today.