Microsoft SQL Server 2005 Service Pack 3 Failover Clustering (KB955706).

I have been trying to figure this out for more than a month, with no success. We have a SQL server cluster with 2 nodes in our environment. I tried to run the SQL Server 2005 Service Pack 3 Failover Clustering and it fails evertime. In addition, Security Update for SQL server 2005 SP2 (KB954607) & Security Update for SQL server 2005 SP2 for failover clustering (KB960090) also failed.

 The error message is:
Installation Failure: Windows failed to install the following update with error 0x80070643: Microsoft SQL Server 2005 Service Pack 3 Failover Clustering (KB955706).

I have tried to check on the nodes, registry, security permissions and they all look ok.

I tried the following suggestions and still fails.

1. Make sure you loginto the Active node with console session
2.. Make sure you donot have any other connections to the passive node(Check in the terminal sessions before you logoff from the passive node).
3. Set both the "tmp" and "temp" variables to a path that does not have a space in it, e.g. "C:\TEMP".  This must be done for both the installers user and the system variables. If a cluster, this change must be made on all nodes.  Refer to 889541     "The TEMP or the TMP environment variable setting may cause an unsuccessful installation of SQL Server 2000 64-bit";EN-US;889541

4. The scheduler service to the set of services that must be running as noted above in the list of services to be left running.  If a cluster, this must be done on all nodes.  Refer to KB articles 910851   "You receive error messages when you try to set up a clustered instance of SQL Server 2005";EN-US;910851

5. Verify the path and availability of original install media via registry key HKLM\Software\Classes\Installer\Products\<guid>\SourceList\LastUsedSource this path must exist and be accessible to the original installation media. If a cluster, all nodes must have this path available with the original installation media.

6. Give the following Local policy settings to the SQL Server Service account.

This account must be a direct member of the local administrators group and been granted the following permissions:


            " Act as Part of the Operating System
            " Bypass Traverse Checking
            " Lock Pages In Memory (Optional)
            " Log on as a Batch Job
            " Log on as a Service
            " Replace a Process Level Token
7. Go thorough the Article

The last try provided me with the following logs:

Any help would be really appreciated.

Who is Participating?
intermakersConnect With a Mentor Author Commented:
Do you have any virtual drives created with subst.exe command line utility? I had some problems with that some time ago.
intermakersAuthor Commented:
Not really. The drives were not created with this utility.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.