Forms using a linked table (using ODBC) keep asking for password when loading.

The form is bound with a linked Oracle table using ODBC, every time when I open the form, it asks for password in ODBC dialog. How could I skip this step using stored password? Thanks.

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

One way around this is to create a passthrough query in stead of linking the table to the database. Create a new query, and close the choose table dialog box, from the query menu, choose sql specific and then passthrough.
Then right click on the blue bar at the top of the query window, and choose properties. click to the right of the odbc connect str (you'll see a button with "..." appear. Choose your odbc connection, or create a new one to your database. You'll get the option to save the password with the odbc string which gets round the above.
Next step is to write the sql statement in native oracle sql (not access jet sql)
Save your query and use it as the record source of your form...
heyday2004Author Commented:
Is any other solution that I could still use the linked ODBC oracle table?  Thanks.
Unfortunately I don't have much experience with oracle table links, and don't have an oracle server to test with, so not 100% sure if the below is is the case....
Is the password defined in the odbc link? When you set up an sql server file DSN you get the option to either verify login using windows nt (i.e. current user of the machine is checked) or to login with user name and password supplied by the user.  In your case you need to supply user name and password in the file dsn, and then when you link the table to access, you should get the option to save the password with the connection string - try removing the link to the oracle table and then reattach the link and see if there is a save password option.... if not you may need to amend your file dsn...

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Did this help?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Access

From novice to tech pro — start learning today.