WSS 3 all documents suddenly write protected ?

Hi -
Im using WSS 3.0 on a SBS 2008 server. (Default installation).
I have suddenly got a issue where all documents in libraries are write protected. This happens on all computers. It is no problem to briowse the WSS site, but documents are write protected.
Any idea of what can be the reason here, and how to fx this.

Kind r

Bjørn-T
btn003Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

melli111SharePoint Administrator / DeveloperCommented:
The only thing I can think of is maybe someone accidently changed the content type setting to Read Only.  Go to the top level of your team site > site actions > site settings > site content types.  Click on "Document" go to Advanced Settings and make sure it's not marked as read only.
0
screen-nameCommented:
Is is just documents?

Can check the policy for webapps,

http://CA:PORT/_admin/policy.aspx

Make sure that someone didnt set all users to read-only or something silly like that.
0
btn003Author Commented:
Hi -

Thanx for good advice. The content type in site settings is ok.
The policy for webapps was read only, and I have now changed it to full control, but still the same error. I also tried to give users access directly here, but no success.

Any othere idea?
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

screen-nameCommented:
Just shooting in the dark now, but did you check the site collection Lock? /_admin/sitequota.aspx

Also, you would not typicall give full control to all users under policy for web app. (not a good idea)

You could also use Sharepointloggingspy to try and see what else might be going on. http://www.codeplex.com/sharepointloggingspy


0
btn003Author Commented:
Hi -
 
The quotas/lock is ok, thanx.

Ill check out the tool.
Next week Ill deploy a new server with MOSS2007. I dont like the SBS2008 pre installed thing. It gives less control over the details.
0
screen-nameCommented:
Ya, i havent messed with it much... But I just dont like its limitations. 75 cal max and such... and too much on a single server.

Good luck.
0
btn003Author Commented:
Hmmm. I solved the problem by reinstalling a clean WSS3 on a single 2008 server.
thanx.

Bjørn.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.