Cisco QOS WAN Interface Bandwidth Allocation

Hi,
I have a 2 x Cisco 871 Router that I am configuring to be at either end of a 10mbps leased line.  I am using QoS on both routers to guarantee bandwidth to Citrix ICA and VOIP data.  My confusion is that the QoS bandwidth is calculating based on the WAN interface max speed of 100mbps where as it will only have 10mbps available over the leased line.  The QoS bandwidth is calculated as a percentage, so 5% is 5000kbps.  

Questions:
Should I change the WAN Interface to 10mbps?
Will that make 5% into 500kbps?
What are the commands to change the WAN (Fastethernet4) to 10mbps?

Show run attached for reference.
Thanks,
Richard
Building configuration...
 
Current configuration : 4903 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Dorking
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 51200 warnings
enable secret 5 $1$3hbr$Tg624pdDZ72ZVaPugRs/R0
enable password ************
!
no aaa new-model
clock timezone PCTime 0
clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
!
crypto pki trustpoint TP-self-signed-947856235
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-947856235
 revocation-check none
 rsakeypair TP-self-signed-947856235
!
!
crypto pki certificate chain TP-self-signed-947856235
 certificate self-signed 01
******************
  	quit
dot11 syslog
ip source-route
!
!
ip nbar port-map custom-01 tcp 5900 
!
!
ip cef
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
username ************* privilege 15 secret 5 **************
! 
!
!
archive
 log config
  hidekeys
!
!
!
class-map match-all VLAN2
 match vlan  2
class-map match-any CCP-Transactional-1
 match protocol citrix
 match protocol finger
 match protocol notes
 match protocol novadigm
 match protocol pcanywhere
 match protocol secure-telnet
 match protocol sqlnet
 match protocol sqlserver
 match protocol ssh
 match protocol telnet
 match protocol xwindows
class-map match-any CCP-Voice-1
 match protocol rtp audio 
class-map match-any Citrix
 match protocol citrix
class-map match-any CCP-Routing-1
 match protocol bgp
 match protocol eigrp
 match protocol ospf
 match protocol rip
 match protocol rsvp
class-map match-any CCP-Signaling-1
 match protocol h323
 match protocol rtcp
 match protocol sip
class-map match-any CCP-Management-1
 match protocol dhcp
 match protocol dns
 match protocol imap
 match protocol kerberos
 match protocol ldap
 match protocol secure-imap
 match protocol secure-ldap
 match protocol snmp
 match protocol socks
 match protocol syslog
class-map match-any VNC
 match protocol custom-01
!
!
policy-map CCP-QoS-Policy-1
 class CCP-Voice-1
  set dscp ef
    priority percent 3
 class CCP-Signaling-1
  set dscp cs3
    bandwidth percent 5
 class CCP-Routing-1
  set dscp cs6
    bandwidth percent 5
 class CCP-Management-1
  set dscp cs2
    bandwidth percent 5
 class CCP-Transactional-1
  set dscp af21
    bandwidth percent 5
 class Citrix
    priority percent 20
 class VNC
    bandwidth percent 5
 class class-default
    fair-queue
     random-detect
!
!
!
!
interface FastEthernet0
 shutdown
!
interface FastEthernet1
 shutdown
!
interface FastEthernet2
 description VOIP Port
 switchport access vlan 2
!
interface FastEthernet3
 description Data Port
!
interface FastEthernet4
 description WAN Port$ETH-LAN$
 ip address 10.100.5.1 255.255.0.0
 ip nbar protocol-discovery
 ip flow ingress
 ip flow egress
 duplex auto
 speed auto
 service-policy output CCP-QoS-Policy-1
!
interface Vlan1
 description Data VLAN
 ip address 10.156.5.1 255.255.0.0
 ip flow ingress
 ip flow egress
!
interface Vlan2
 description VOIP VLAN
 ip address 10.157.5.1 255.255.0.0
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
!
ip access-list extended VNC
 remark VNC 5900
 remark CCP_ACL Category=257
 remark VNC Port 5900
 permit tcp host 10.156.8.1 10.75.0.0 0.0.255.255 eq 5900
!
dialer-list 1 protocol ip permit
!
!
!
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 privilege level 15
 password ************
 login local
 transport input telnet ssh
!
scheduler max-task-time 5000
end

Open in new window

DownsITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ksims1129Commented:
Yes you should change the bandwidth to 10Mbps, this will also work for routing metrics also. to change the bandwidth on a interface FA/04 issue the following command

interface fa0/4
bandwidth 10000

right now you are only allocating 3% to voip packets.
hope this helps
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Don JohnstonInstructorCommented:
You need to define the reference bandwidth on the fastethernet 4 interface.



int fa4
 bandwidth 10000

Open in new window

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.