Invalid Report File Path Visual Studio 2005

Hi Experts,
I have a small reports website used as a portal to execute crystal reports in a run time environment.   I have multiple crystal reports running at the moment.  I have added a more complicated Crystal report using multiple databases.  When I add a CrystalReportViewer in Visual Studio 2005 and assosiate the report, normally I see the report as a representation to show it has been connected to the webpage.
This doesn't happen.  I do not receive any errors.  In run time the page executes with no data, just the toobar at the top of the webpage.
When I click on parameters in the properties box in VS 2005 I receive the error" Invalid Report File Path" so I understand the report has not connected using the CrystalReportViewer.
I write all my reports in Crystal XI.
Apart from the multiple databases (from the same location) I can not see any differences in the older reports.  
Any help would be welcomed.
Who is Participating?
chrislindsayConnect With a Mentor Author Commented:
Hi mlmcc,
The data source is tfrom the same serverinstance sql server, just different databases.  I copied and pasted the sql statement avaliable in the database menu in crystal and created a ADD COMMAND statement.
I created an aditional ADD COMMAND statment for the second database.
Connected the data sources in Crystal to form a relationship and rebuilt the report.
It worked in runtime!

Are you using the multiple databases in subreports?

Crystal in general wants a single data source for a report.  A subreport can have a different data source.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.