Active Sync for mobile phones

Can anyone help.  I have a user with a Nokia E71 trying to login to an SBS2003 OWA.  The user has 4 items of information to fill in:

Exchange Server:
Secure Connection: Yes
Username:
Domain:

Exchange Server:  we have used the full internet address so mail.domain.com/exchnage
Secure Connection: Yes there is a Thwate certificate installed
Username:  we have tried name plus domain\name
Domain: we have tried domain.local and mail.domain.com and left it blank

In the IIS logs I can see the user coming through:
1. 2009-05-27 13:58:01 W3SVC1 10.1.0.1 OPTIONS /Microsoft-Server-ActiveSync User=domain%5Cjulianl&DeviceId=IMEI354208031921118&DeviceType=IMEI354208031921118 443 domain\username 82.132.136.165 NokiaE71/2.05(5)MailforExchange 401 1 1326

but the device says either uers incorrect or can't find server depending on what seetings are used.  I'm sure the server OWA / Active sync is OK.

Does anyone have any suggestions?

Thanks
dcleaverAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

akrdmCommented:
I would try the following;

Exchange Server: mail.domain.com/exchange
Secure Connection: Yes
Username: Enter just the username (Don't do domain\user)
Domain: Enter just the Domain name (don't put .local or mail.domain.com)

If this does not work please post back.
0
dcleaverAuthor Commented:
Hi
Returns system error.
Thanks

 
0
TheIteam3Commented:
Please verify the OMA (not OWA) site is working correctly. https://mail.domain.com/oma
Active sync uses the OMA for communication.
If ti works, you will get promted for credentials, and after, get a page with a little text, nothing useful.
Also, try mail.domain.com or mail.domain.com/oma
0
Exploring SQL Server 2016: Fundamentals

Learn the fundamentals of Microsoft SQL Server, a relational database management system that stores and retrieves data when requested by other software applications.

dcleaverAuthor Commented:
OK, This is what is displayed after typing in the username and password.

Server Error in '/OMA' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>
 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>
 
0
TheIteam3Commented:
Try going to https://<server>/oma on the SBS itself. That should allow access to the error message. No need to rewrite the config file just yet.
0
dcleaverAuthor Commented:
OK Error below, thanks!

The source code that generated this unhandled exception can only be shown when compiled in debug mode. To enable this, please follow one of the below steps, then request the URL:

1. Add a "Debug=true" directive at the top of the file that generated the error. Example:

  <%@ Page Language="C#" Debug="true" %>

or:

2) Add the following section to the configuration file of your application:

<configuration>
   <system.web>
       <compilation debug="true"/>
   </system.web>
</configuration>

Note that this second technique will cause all files within a given application to be compiled in debug mode. The first technique will cause only that particular file to be compiled in debug mode.

Important: Running applications in debug mode does incur a memory/performance overhead. You should make sure that an application has debugging disabled before deploying into production scenario.  

Stack Trace:


[InvalidOperationException: Collection was modified; enumeration operation may not execute.]
   System.Collections.ArrayListEnumeratorSimple.MoveNext() +2756158
   Microsoft.Exchange.OMA.Tracing.OmaTrace.set_DebugOutputTracing(Boolean value) +167
   Microsoft.Exchange.OMA.UserInterface.Global..ctor() +262
   ASP.global_asax..ctor() +5

[TargetInvocationException: Exception has been thrown by the target of an invocation.]
   System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck) +0
   System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache) +103
   System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache) +261
   System.Activator.CreateInstance(Type type, Boolean nonPublic) +66
   System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) +1036
   System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) +114
   System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext context) +184
   System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context) +106
   System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +214

 
0
TheIteam3Commented:
Looks like we found the problem. The hard part is fixing it.

It looks like the OMA portion in IIS is damaged.
Please see the below article, it should be a good help.

http://www.petri.co.il/fixing_a_damaged_or_incorrectly_configured_owa_2003_installation.htm

Please note, this is a fairly major fix, and will affect production. Plan accordingly.

Below are a couple links that may also help.

883380 How to reset the default virtual directories for Outlook Web Access
in Exchange Server 2003

http://support.microsoft.com/?id=883380


Exchange ActiveSync and Outlook Mobile Access errors occur when SSL or
forms-based authentication is required for Exchange Server 2003

http://support.microsoft.com/default.aspx?kbid=817379

More information is addressed in the following article, please check into
the following document:

Step-by-Step Guide to Deploying Windows Mobile-based Devices with Microsoft
Exchange Server 2003 SP2

http://www.microsoft.com/technet/its...oy/msfp_2.mspx
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dcleaverAuthor Commented:
Hi

I have already run http://www.petri.co.il/fixing_a_damaged_or_incorrectly_configured_owa_2003_installation.htm earlier today, but will look at the other links.
Will update asap.

Thanks
0
dcleaverAuthor Commented:
OK, goine through the list and now I get this

 Attempting to send OPTIONS command to server
  OPTIONS response was successfully received and is valid
 Additional Details
  Headers received: MicrosoftOfficeWebServer: 5.0_Pub
Pragma: no-cache
Public: OPTIONS, POST
Allow: OPTIONS, POST
MS-Server-ActiveSync: 6.5.7638.1
MS-ASProtocolVersions: 1.0,2.0,2.1,2.5
MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,ResolveRecipients,ValidateCert,Provision,Search,Notify,Ping
Content-Length: 0
Date: Wed, 03 Jun 2009 12:19:42 GMT
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET

 
 
 Attempting FolderSync command on ActiveSync session
   
 
 Attempting initial sync (no data) for Inbox folder
  An Error occurred when testing the Sync Command
 Additional Details
  An HTTP 403 forbidden response was received. The response appears to have come from Unknown. Body is: <body><h2>HTTP/1.1 403 Forbidden</h2></body>  
 
Any ideas?
0
TheIteam3Commented:
This is a credentials issue. Verify the correct username and password are being used. also verify the security permissions on the OMA in IIS, don't forget the check the restricted ip section.
0
dcleaverAuthor Commented:
Actually, I was wrong on my last post (the restart of IIS failed.  It seems that Method 2 found in the link http://support.microsoft.com/default.aspx?kbid=817379 resolved the issue.  Thank you so much!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.