How can I grant VPN access to individual vlans on an asa 5505.

I have an office that is running two separate vlans, with no ability to communicate between them.  I need to add VPN access, but the users of each vlan cannot be allowed access to the other.
How can I setup two separate vpn groups, and configure them to only be able to access the appropriate groups?
ASA# show run
: Saved
:
ASA Version 7.2(4)
!
hostname ASA
domain-name PFB-DJ.local
enable password ******************** encrypted
passwd ******************* encrypted
names
!
interface Vlan1
 nameif insidePFB
 security-level 100
 ip address 192.168.10.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address xx.xxx.xxx.xxx 255.255.255.192
!
interface Vlan3
 no forward interface Vlan1
 nameif insideDJ
 security-level 100
 ip address 192.168.20.1 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
 switchport access vlan 3
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name PFB-DJ.local
access-list in_to_PFB extended permit tcp any interface outside eq 3390
access-list in_to_PFB extended permit tcp any interface outside eq 3391
access-list in_to_PFB extended permit tcp any interface outside eq 3392
access-list in_to_PFB extended permit tcp any interface outside eq 3393
access-list in_to_DJ extended permit tcp any interface outside eq 4490
access-list in_to_DJ extended permit tcp any interface outside eq 4491
access-list in_to_DJ extended permit tcp any interface outside eq 4492
access-list in_to_DJ extended permit tcp any interface outside eq 4493
access-list PFBout extended permit ip any any
access-list DJout extended permit ip any any
access-list out_to_in extended permit tcp any interface outside eq 3390
access-list out_to_in extended permit tcp any interface outside eq 3391
access-list out_to_in extended permit tcp any interface outside eq 3392
access-list out_to_in extended permit tcp any interface outside eq 3393
access-list out_to_in extended permit tcp any interface outside eq 4490
access-list out_to_in extended permit tcp any interface outside eq 4491
access-list out_to_in extended permit tcp any interface outside eq 4492
access-list out_to_in extended permit tcp any interface outside eq 4493
pager lines 24
logging asdm informational
mtu insidePFB 1500
mtu outside 1500
mtu insideDJ 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (insidePFB) 1 0.0.0.0 0.0.0.0
nat (insideDJ) 1 0.0.0.0 0.0.0.0
static (insidePFB,outside) tcp interface 3390 192.168.10.10 3390 netmask 255.255.255.255
static (insidePFB,outside) tcp interface 3391 192.168.10.50 3391 netmask 255.255.255.255
static (insidePFB,outside) tcp interface 3392 192.168.10.51 3392 netmask 255.255.255.255
static (insidePFB,outside) tcp interface 3393 192.168.10.52 3393 netmask 255.255.255.255
static (insideDJ,outside) tcp interface 3390 192.168.20.10 3390 netmask 255.255.255.255
static (insideDJ,outside) tcp interface 4490 192.168.20.10 4490 netmask 255.255.255.255
static (insideDJ,outside) tcp interface 4491 192.168.20.50 4491 netmask 255.255.255.255
static (insideDJ,outside) tcp interface 4492 192.168.20.51 4492 netmask 255.255.255.255
static (insideDJ,outside) tcp interface 4493 192.168.20.52 4493 netmask 255.255.255.255
access-group PFBout in interface insidePFB
access-group out_to_in in interface outside
access-group DJout in interface insideDJ
route outside 0.0.0.0 0.0.0.0 xx.xxx.xxx.xx 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa authentication ssh console LOCAL
http server enable
http 192.168.10.0 255.255.255.0 insidePFB
http 192.168.20.0 255.255.255.0 insideDJ
http 192.168.1.0 255.255.255.0 insidePFB
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh 192.168.10.0 255.255.255.0 insidePFB
ssh 192.168.20.0 255.255.255.0 insideDJ
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
 
username admin password SmS36vA84mYsPM8O encrypted privilege 15
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:93cf95a9dab3b73b4115d943dada35b6
: end

Open in new window

HelterAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MikeKaneCommented:
You would setup the site to site L2L vpn as usual.   Then apply a vpn filter to the tunnel group to control access across the vlan.  

PFB Vlan        DJ Vlan  
      |                  |
         ASA Firewall
                |
              Internet
                |
           Remote ASA
                Apply filter here
                 |
              Remote lan


Here's the doc on how to do it.
http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a00808c9a87.shtml







0
HelterAuthor Commented:
I'm not adding a site to site vpn, I'm adding client access vpn.  I need it to grant access to either network depending on the vpn group or user.
0
HelterAuthor Commented:
It looks like it. How would I configure that to allow for two groups to have access to only their own vlan?
0
2PiFLCommented:
Create 2 differnt Tunnel Groups each with their own group policy granting access to only their vlan.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.