• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 847
  • Last Modified:

How do I make a folder downloadable on my FTP server?

I have a folder on my FTP server that I need to allow people to see and download from and can't seem to figure out how.

Ex: www.xyz.com/docs/whatever

basically they need to be able to see the file structure and download from there.

Any ideas?
  • 2
  • 2
1 Solution
Red-KingIT ManagerCommented:
Are you using a windows or linux based FTP server?

For Windows
If you want everyone to be able to access the folder you need to give the group "Everyone" read permissions as a minimum.
If its people who log in you should add them all to a particular group(s),  add these groups to the list of allowed users and give them read permissions as a minimum
Right click the folder -> properties -> security tab

For Linux
You need to change the permissions on the folder using the chmod command

chmod 755 whatever

7 = read, write, execute
5 = read, execute
4 = read
1 = execute

755 = 7 for the owner of the file, 5 for the group of the file, 5 for everyone else
754 = 7 for the owner of the file, 5 for the group of the file, 4 for everyone else

You may need to add the user who'll be accessing the folder to its group in linux.

usermod -G <groupname> <username>

That's not the most secure way to go about it but if security isn't a concern for you then that will do it. Otherwise you need to look up Access Control Lists for linux directories.
ZkdogAuthor Commented:
Windows server using Filezilla to connect.  

Under File Permissions, I have everyone with read access but am still getting a 403 Forbidden message when trying to bring it up.
ZkdogAuthor Commented:
Now this is odd as well....Previous files I've put in the "docs" directory seem to pull down fine, but after placing the new files in the same directory I can't access them.  These are .tif image files if that may have anything to do with it.
Red-KingIT ManagerCommented:
Its unlikely that the .tif extension is the cause of the problem.

Firstly try to access the FTP using a different ftp client (the command line client or a web browser). This will show if the problem is with filezilla.
If you're getting a permissions error its unlikely that its the client tho.

If its particular files in the directory that are not accessible then you will need to check the security permissions for each file (they're probably all the same).
It could be that there's a deny permission that is causing the problem. A deny overwrites an allow permission, its always better to avoid using a deny permission and just use an allow permission or no permission.

To find out what the actual permissions are on a file for a particular user you need to access the security tab of the files properties.
Once there follow these steps;

1. Click the "Advanced" button to open the advanced security settings dialogue box.
2. Selec the "Effective Permissions" tab.
3. Click the "select" button.
4. Type in the name of the user trying to access the file through the ftp server (if you're using anonymous connections open the IIS manager and then the properties of the ftp site. Open the security accounts tab and check the username)
5. Click the "check names" button to make sure the user is found. (You may have to change the location to the local computer instead of the domain)
6. Hit "ok" and you'll be shown the permissions that user has on the file.

Typically you'd want the ftp user to have at least the following permissions;

Traverse Folder / Execute file
List Folder / Read Data
Read Attributes
Read Extended Attributes
Read Permissions

Now go back to the "Permissions" tab.
A quick way to obliteate the permissions on the current file and restore the permissions of the parent folder is to remove the check from the box for "Inherit from parent the permission entries ..."
This will pop up a dialogue box that will allow you to copy the permissions from the parent or to remove all the current permissions.
Click "remove" and it'll wipe all permissions, It will also give yiou a warning that only the owner will be able to change permissions (if you're not the owner go to the owner tab and change yourself or your group to the owner).
Click apply and the file will now have no permissions assigned, a blank slate.
Now if you put the check bac in the "Inherit from parent the permission entries ..." you'll get the permissions back from the parent folder.

Now try to access the file via your FTP client.

If its not an option to wipe the current permissions of the files then you need to find out what groups the FTP user is a member of in Active Directory or the local user and groups. You will then need to check each of the groups effective permissions on the file as described above and modify the relevant groups permissions on the files.

Hopefully you'll be able to get the files this way. If not there may be some other issue at play here.


Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now