Testing Outlook Anywhere

Hi

I am running Outlook 2007 with Exchange 2003/Exchange 2007 environment.

I have set my Outlook to use Outlook Anywhere, but I would like to test. In the Account Settings, I have checked the boxes for:

On fast networks, connect using HTTP first, then TCP/IP
On slow networks, connect using HTTP first, then TCP/IP

But - how will I know if I am connected via Outlook Anywhere, or just using the LAN?

Cheers!
LVL 3
kam_ukAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

shadowlesssCommented:
Since you have checked "On a fast network, connect using HTTP first, and then by using the TCP/IP", Outlook will connect to the server via HTTP by default when on the LAN. Unless http connection is unavailable, it will not convert to TCP/IP connection.

Fast connection defined as a connection that is faster than 128 kilobits per second

More Info Here
http://technet.microsoft.com/en-us/library/aa996069(EXCHG.65).aspx
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kam_ukAuthor Commented:
Sure - but how do I know if I am on an HTTP connection (Outlook Anywhere) or this has failed and I have reverted to TCP/IP?
0
shadowlesssCommented:
You hold the CTRL button down while right-clicking the Outlook icon in the task bar. On the drop-down menu click Connection Status.  It will show either https or tcpip
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

shadowlesssCommented:
to clarify..

You hold the CTRL button down while right-clicking the Outlook icon in the task bar (icon in the system tray). On the drop-down menu click Connection Status.  It will show either https or tcpip
0
kam_ukAuthor Commented:
Yep, thanks - all the connections are TCP/IP, so I guess this is not working.

Out of interest - I have loads of different Exchange servers listed (they are all in my Org), with the type MAIL, then a DC with connection type Directory, and another two Exch servers with connection type "Public Folders"

Do you know why there are so many simultaenous connections? Surely I would only need a connection to one DC and one Exchange server? Or possibly even one Exchange server only, since surely the Exchange server speaks to the DC itself?

0
kam_ukAuthor Commented:
Hmmm, actually just tried again, and this time connections to some of the Exch servers are HTTPS, and some are TCP/IP...any idea why this is? How do I know if I am using Outlook Anywhere or not? ;)
0
shadowlesssCommented:
All connections should read HTTPS

Ref - http://blogs.techrepublic.com.com/networking/?p=292

Testing RCP over HTTPS

There are two ways to test whether or not RCP over HTTPS is working. The first is to try connecting from outside of your internal network. The second is to filter all ports but 443 while on the internal network to make sure that Outlook cant connect via the standard TCP/IP protocols. To apply such a filter, go to the advanced TCP/IP properties of your network connection, select filtering, and deny all but port 443.

One important thing to note is that if youre connecting Outlook to the Exchange server for the first time, then you must be on the internal network using TCP/IP. Im not sure why this is but found out using trial and error.

To check whether Outlook has connected via HTTPS you must hold down [Ctrl] and click on Outlooks taskbar icon. Select Connection status and you will see a list of all connections between Outlook and the Exchange server. These should all be of the type HTTPS.
0
kam_ukAuthor Commented:
"To check whether Outlook has connected via HTTPS you must hold down [Ctrl] and click on Outlooks taskbar icon. Select Connection status and you will see a list of all connections between Outlook and the Exchange server. These should all be of the type HTTPS"

Will this show attempted connections as well? Would I be correct that saying, in my case, Outlook is attempting a connection on HTTPS [which is why I can see them], these are not working, so it fails back to TCP/IP?

Also - any idea why there are multiple Exchange servers in there, surely Outlook only needs to be speak to one?
0
shadowlesssCommented:
"Will this show attempted connections as well? "
The Req/Fail column shows  you how many requests were made and how many failed for that particular connection.  The Avg Resp column shows you the average amount of time it took to respond to those requests.


"Also - any idea why there are multiple Exchange servers in there, surely Outlook only needs to be speak to one?"
It is not uncommon to see multiple directory connections.  Outlook makes multiple connectionsfor GAL lookups


To verify that Outlook 2003 client connects to Exchange Server 2003
Click Start, click Run, type outlook /rpcdiag, and then click OK.
Type your credentials in the User name box and in the Password box, and then click OK.
If HTTPS appears in the Conn column in the Exchange Server Connection Status window, a service is connected by using RPC over HTTP.
Ref - http://technet.microsoft.com/en-us/library/aa996088(EXCHG.65).aspx
0
shadowlesssCommented:
Is this issue resolved?
0
ppsditCommented:
I have been having the same problem as Kam uk.  I spent weeks trying to figure it out.  I know have the solution.  And it is entirely a windows bug not documented anywhere:

I am using Windows Server 2008 x64. It turned out to be a bug with IPv6. See the solution at http://blog.aaronmarks.com/?p=65 .
I disabled IPv6 on my LAN card network connection and added the FQDN of the server to my HOSTS file and it worked without the need to change the registry settings as described in this link. All connections are now made over HTTPS.

everything now works internally and externally over https
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.