Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1438
  • Last Modified:

changing network interface names in Suse linux

Hi All,

I have Suse linux 9.3 installed on HP DL585 server.
There are 2 on-board NICs, and initially they are shown as eth0 and eth1.
After putting a quad-port NIC card, the on-board NIC names changed to eth4 and eth5. Add-on NICs got eth0 through eth3 names.
I want to change the NIC name from eth4 to eth0, I tried by adding PERSISTENT_NAME='eth0' to scripts in /etc/sysconfig/network/.
When I rebooted or /etc/init.d/network restart, it says
rename from eth4 to eth0 failed, file already exists. something like this.
I tried some other options but in vain.

Please let me know how can I fix this.
Thanks in advance.
0
vmwarecv1
Asked:
vmwarecv1
1 Solution
 
qualipsoftCommented:
1. check the udev rules under /etc/udev/rules.d/70-persistent-net.rules (file name may differ in your distribution). These rules are used to automatically rename interfaces too.

2. It is a known issue with the current Linux kernels that interface name collisions occur, for the persistent names, use either higher numbers (e.g.: eth10, eth11, ...) or even a different prefix (e.g.: peth1, peth2, ... for "persistent"-eth) although this *may* cause issues with programs that rely on this prefix, but these are few.

There has been various discussions over a new set of kernel-supported naming rules in the linux net mailing list... change is coming.

In the mean time, good luck!
0
 
vmwarecv1Author Commented:
Change the scripts under /etc/sysconfig/network-scripts and comment out hardware info.
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

Tackle projects and never again get stuck behind a technical roadblock.
Join Now