SCE 2007 Management Server shows computer has not been contacted for most systems

I have installed SCE 2007 with SP1 and after 3 days the management server plus all local systems show "This computer has not been contacted yet" with an error on deployment and inventory and the Operating System is showing Windows 0.0
Laptops that are working over a VPN show the correct OS, software shows as up to date but updates are still showing unknown.
We do not use the XP firewall (we use Symantec Endpoint). I have tested RPC and fileshare connectivity by opening up eventviewer.msc from the management server to the affected workstations.
I found that the Selfupdate virtual directory was missing so I added it in manually as recommended on both the default web site (port 80) and the wsus administration site which operate on the custom port (8530 and 8531). I can connect from both the management server and from a local client. I have tried to force a reconnect using wuauclt detectnow but this makes no difference.
I also tried changing the group policy Windows Update settings (it is being applied OK) from https://managmentserver.domain.local:8531 to http://managmentserver.domain.local:8530 in case that was the issue.
I am now completely stumped as to what the problem may be. I'd like to get these basics functioning before moving on the the other errors that are now fillling up the alerts to do with performance counters.
Thanks very much in advance for any help given.
Fester7572Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Fester7572Author Commented:
OK, moved a step closer. It looks like our proxy server is impacting on the WSUS component in some way. Weird thing is that I don't have proxy enabled in IE on the management server or any of the other servers, only the XP workstations. WSUS Administration is now listing my servers but showing the IP of our proxy server???
Updates are still showing as unknown so I guess we are looking at a WSUS/Proxy issue in some way.
The proxy server is the Smoothguardion module of Smoothwall Advanced Firewall
0
DonNetwork AdministratorCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

Fester7572Author Commented:
Ran this on the management server. Let me know if you need it run on a client workstation
WSUSServerDiagnostic.jpg
0
DonNetwork AdministratorCommented:
has to be run on clients ;-)
0
Fester7572Author Commented:
DOh! :-)
FYI, although it was the management server the results in WSUS are the same. Both internal clients and servers, regardless of whether IE is set to use the proxy are showing the IP of the proxy server and are not updating their status. Weird?
WSUSClientDiagnostics2.jpg
WSUSScreenShot.jpg
0
DonNetwork AdministratorCommented:
Ok, go over the link above
0
DonNetwork AdministratorCommented:
0
Fester7572Author Commented:
OK, this just got weirder,  while reading through the procmon output one of the DCs just sync'd, while the other stubbornly refuses to play ball. Both are setup identically. I'm hoping that if one works that means the WSUS permissions must be OK.
0
Fester7572Author Commented:
Cracked it. Turned out to be a setting on the proxy server. Needed to make sure that the local domain was added to the list of those that did not require authentication. Weird as you would have thought that if IE was set to not use a proxy it wouldn't matter. Hey ho!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.