We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

How to install CRM Data Connector for SQL Server Reporting Service on multiple reporting instances?

Medium Priority
1,256 Views
Last Modified: 2012-05-07
Hi
I tried to install a the SRSS on a SQL Server 2005 with Reporting Service. The Default instance is working, but i need to install SRSS also for a Instance SQL01\INSTANCE1

I used this command:
SetupSrsDataConnector /CONFIG c:\srsdataconnector\install-config.xml

Contents of install-config.xml:
<crmsetup>
  <srsdataconnector>
    <configdbserver></configdbserver>
    <autoupdateconfigdb>1</autoupdateconfigdb>
<reportserverurl>http://sql01/Reportserver$instance1</reportserverurl>
    <autogroupmanagementoff>0</autogroupmanagementoff>
    <instancename>instance1</instancename>
    <configsku>OnPremise</configsku>
    <!-- Set enabled = true for DB webstore integration.  Set configdb="true" for config db webstore integration-->
    <webstore enabled="false" configdb="false" />
    <monitoring>
<!-- Monitoring service account name and password. It can not be local system or network service account -->
      <serviceaccountname></serviceaccountname>
      <serviceaccountpassword></serviceaccountpassword>
    </monitoring>
  </srsdataconnector>
</crmsetup>


I am unsure about what must be typed in the configDB field and which service account has to be used. Has someone tried that before and can paste me a sample config of that?

When i try to install as above i get a error message: OpenRegKey(SOFTWARE\Microsoft\MSCRM failed.

Thanks in advance for your help.

Martin
Comment
Watch Question

Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
Found solution as described
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.