Cisco Router: Able to ping Interface but not network Behind it.

Hi Guys,

Just configured a router. There are two directly connected interfaces. I am able to ping to both inteferaces. Interface f0/0 ip address is and all of 172.25.x.x network is accessible. Interface f0/1 IP address is , I am able to ping the interface but all of 172.26.x.x network is inaccessible. Can't figure out the reason. I have modified the Duplex and Speed in every possible way but still no luck. The Configuration is pasted below. No Access Lists are configured.
All and Any help will be appreciated.

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to, timeout is 2 seconds:
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
Building configuration...
Current configuration : 1998 bytes
! Last configuration change at 22:24:09 MET Sat Jun 27 2009
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no service dhcp
hostname IN-3640-Int-BU
no logging on
no aaa new-model
resource policy
clock timezone MET 5
ip flow-cache timeout active 1
ip cef
interface FastEthernet0/0
 description $ETH-LAN$
 ip address
 ip flow ingress
 ip flow egress
 ip nbar protocol-discovery
 ip route-cache flow
 speed 100
interface FastEthernet0/1
 ip address
 ip flow ingress
 ip flow egress
 ip nbar protocol-discovery
 ip route-cache flow
 duplex auto
 speed 100
ip http server
ip http authentication local
ip flow-export source FastEthernet0/0
ip route
ip route
ip route
ip route
ip route

Open in new window

LVL 12
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Lets see if the routing table uses F0/1 for network

#show ip route
Hilal1924Author Commented:
IN-3640-Int-BU#sh ip route
Routing entry for
  Known via "connected", distance 0, metric 0 (connected, via interface)
  Routing Descriptor Blocks:
  * directly connected, via FastEthernet0/1
      Route metric is 0, traffic share count is 1

There you go ..All ok

Thanks for responding
Ok it seems packets are leaving the right interface.

Q1.  Why to you force the duplex and speed ?   Why not auto ?
         Try under the interface #speed Auto

Test Ethernet port:
We have to plug a switch or pc, directly into the F0/1 with a fixed IP and test if we can ping it from the router.   E.g. PC/Switch with IP Mask

Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Hilal1924Author Commented:
I kept speed and duplex at auto, that didn't work either. I attached a laptop to the int f0/1 with IP Interface not accessible from laptop and laptop not accessible from router.

I kind of think the interface is not behaving :)
Does the link light on the Laptop/Router show that they are connected when you plug them in ?

I you are on the router console or telnet with #term mon
you should see the F0/1 int up down events on the console

From Router to PC you might need a cross over cable.
Hilal1924Author Commented:
Well link light glows up al right but the activity light doesn't blink. And yes interface does come up.

Anyway I connected a switch in between PC and router also, didn't work either.
add command: IP routing
Might be usefull
I would suggest loading a snffer on the pc to see if we can see the incoming ARP's and ICMP pings from the router.
not .com
> add command: IP routing
> Might be usefull
The problem is the router cannot even ping directly connected IP's
Hilal1924Author Commented:
Here is the show interface output. I hope it is useful

IN-3640-Int-BU#sh int f0/1
FastEthernet0/1 is up, line protocol is up
Hardware is AmdFE, address is 0050.0f05.5022 (bia 0050.0f05.5022)
Internet address is
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:02:08, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 1000 bits/sec, 2 packets/sec
0 packets input, 0 bytes
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
834 input errors, 0 CRC, 0 frame, 0 overrun, 834 ignored
0 watchdog
0 input packets with dribble condition detected
77502 packets output, 4953988 bytes, 0 underruns
0 output errors, 0 collisions, 5 interface resets
0 babbles, 0 late collision, 0 deferred
18 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

There are couple of things that worry me:
1) Input Errors = 834
2) 18 lost carrier

Any Suggestions ??
Yes, try new patchcable first, and other port on switch
Hilal1924Author Commented:
Hi JanSc,

I have already tried that. Even used multiple cables and fresh ones. Didn't work :(
Perhaps you can check the switchport where router is attached, for errors as well.
Looks like interface problem to me. Input errors most times come from attached switch or defective cable.
Hilal1924Author Commented:
Like I said I connected my PC directly with the router. And also via layer2 switch. Both times it didn't work which sort of slidifies my suspicion that the router interface is not ok.
One thing that baffles me though is that why would it respond to icmp when the interface IP is selected.
Because there is a difference between physical layer 1 interface, and ICMP towards MAC address on L2 in this router.

It seems to be a hardware problem ....

To exclude Hardware problem interface, cables and IOS bugs try to switch over the configuration. So configuration fa0/0 will be reconfigured to fa0/1 and fa0/1 will be fa0/0. Switch the cables and see what happens.

If the problem stay the same, with other words 172.25. has now problems and 172.26 is working now fine --> Hardware problem fa0/1 --> if the problem switch over from interface to interface then it is a IOS or configuration issue ... and is located on th 172.26 site. How about "no ip subnet-zero" .... You never know ...

Set the default gateway on your PC as the ip address of the router  F0/1 interface and
match the subnet mask of the internal network to the F0/1 interface subnetmask of the router.
>> 834 input errors, 0 CRC, 0 frame, 0 overrun, 834 ignored
Ignored - Number of received packets ignored by the interface because the interface hardware ran low on internal buffers.

Were we are now.
1. PC directly connected to router port. (No ping response) (There is a link light)
2. Router port switched to "auto speed" and "auto duplex"
3. Routing seems ok. (# sh ip route)

1. Tried new patch cables ?? (wiscom: suggested)
2. When connected to a cisco switch, does "#sh cdp neighbor" show the connection ?
3. Have you swapped the config on Fa0/0 and Fa0/1 (wicom: suggested)
         Check if the problem follows the port or the config.

Hilal1924Author Commented:
Hi Diepes,

Here is the answer to your questions:

1. Tried new patch cables ?? (wiscom: suggested) : Yes ..Still no luck
2. When connected to a cisco switch, does "#sh cdp neighbor" show the connection ? ..Yes
3. Have you swapped the config on Fa0/0 and Fa0/1 (wicom: suggested) ..No coz the router is in production and do't want it to go down on me. Might try it on Friday.

Meanwhile I ordered a new router, should be here by tomorrow. The 172.26.x.x network is currently routed via a windows server :)
         Check if the problem follows the port or the config.
Hilal1924Author Commented:
Unfortunately there was no real solution to this issue. I could not get the router up. So had to buy a new one. Thanks everybody for your support and help.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.