Small Business Server - no external email after password change

Hi there, I have recently taken over the admin of server and as such changed the server admin password, to do this I had to change the password policy and now it looks like no one can send or recieve email externaly.

Internal seems fine.

HELP!
LVL 1
MXDEWDAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Alan HardistyCo-OwnerCommented:
Check to see if you have any services that are not running and that are reliant on the Administrator User / Password.
Click on Start, Run, (type) services.msc (press enter)
Click on the Startup Type column heading (this will sort all the processes into startup order) automatic items should appear at the top of the list.
Look down the list for items that are automatic and not started.  Try to start them.  If they fail to start, look at the Log On As column and if they don't say local system, check the username / password combination and if they are using the Administrator account, change the password.  Check all the non-started items and reset all relevant passwords and then try starting the services again.
You will hopefully get them all going again.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MXDEWDAuthor Commented:
hey Alan... thanks for the quick response.

I have 2 services that were not started... mail marshal engine and performance logs and alerts.

Started Mail marshal OK but Performance logs and alerts failed to start - came back with an error... changed the password for the service but made no change.

I have now confirmed that external mail is working OK. I can only assume that the mail marshal service had something do do with it. I wonder why this would not have started on re-start????
0
Alan HardistyCo-OwnerCommented:
Glad you are running again - sometimes services just refuse to start for no reason.  Check the application event logs and you might see a reason.
FYI - Performance logs and Alerts never runs - it only runs when it needs to so you can ignore this service.
Thanks for the points.
Alan
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Alan HardistyCo-OwnerCommented:
Mail Marshall is your Anti-Virus / Anti-Spam software, so without this service running, no mail would come in as this service intercepts mail first, before it is allowed to pass to your store.
0
MXDEWDAuthor Commented:
HI Alan... thanks for the additional info - it all helps!

Regards Jason
0
Alan HardistyCo-OwnerCommented:
My pleasure.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.