Solved

Xampp running were apache keeps sroping

Posted on 2009-06-28
20
1,091 Views
Last Modified: 2013-12-17
I am running xampp version xampp-win32-1.7.0-installer
and have reset the  xampp/apache/conf/httpd.conf  to ports 85 instead of 80
apache is set up and started but the apache on xampp control is flakey and keeps stoping
it also keeps displaying 80 in the status even though i have set it up for port 85

i have been trying for several months on and off to get this running correctly with eclipse php debuger running

the platform is vista home prem
xampperror.png
0
Comment
Question by:sydneyguy
  • 15
  • 3
  • 2
20 Comments
 
LVL 5

Expert Comment

by:sscotti
ID: 24733079
Are you sure that you have modified the working httpd.conf file?
Do you have another server application running on port 80 or port 85?
0
 

Author Comment

by:sydneyguy
ID: 24734106
i am guessing yes but when i run the xampp-portcheck it just crashes and when i try to run any port checking in cmd it does not show any thing so i thought move the ports and i can get the http://localhost:85 to show data info files not at the moment but could before. and it actually works there is something that i am missing but not sure what httpd.conf its using ofr the ports but this has been modified
0
 
LVL 30

Assisted Solution

by:IanTh
IanTh earned 200 total points
ID: 24735619
what version of xampp are you using
what os are you running
are your running a virus checker and have you set that up to allow xampp
0
 
LVL 5

Accepted Solution

by:
sscotti earned 300 total points
ID: 24735703
If you can search your system for httpd.conf file names check to see if there are multiple httpd.conf file and where they are.  If you changed the port to 85 in the active file it should be reflected in XAMPP.  Make sure you modified the correct file.

Are you running something else on port 80?  If yes, and if XAMPP is configured to run on 80 you will get an error on startup because 80 is busy.  That is what it looks like is happening.

There is usually an error.log for apache.  See if you can pull that up and get more detailed information about what is happening.
0
 

Author Comment

by:sydneyguy
ID: 24741235
i have found the file that it uses by runing the xampp_start,exe which tells me which  httpd.conf  file it is using so i know that its using the one in xampp/apache/conf/httpd.conf file  and have checked this and it is defenetly set at 85 for both port addresses
# Change this to Listen on specific IP addresses as shown below to
# prevent Apache from glomming onto all bound IP addresses (0.0.0.0)
#
#Listen 12.34.56.78:80
Listen 85

# If your host doesn't have a registered DNS name, enter its IP address here.
#
ServerName localhost:85
 
si this is set but it still shows 80
I ahve also searched for all other httpd.conf and renamed them so they cannot interfere

There is usually an error.log for apache.  See if you can pull that up and get more detailed information about what is happening.
I have attached a image of all the apache error logs i found but were do i start

Do you have another server application running on port 80 or port 85? have used the cmd port display as well as the xampp port display which keeps crashing, but cannot see any conflict

i am using xampp-win32-1.7.0-installer

have turned off my virus checker for testing and running vista home prem

xamppShot.png
0
 

Author Comment

by:sydneyguy
ID: 24741240
see image error logs
errors.png
0
 

Author Comment

by:sydneyguy
ID: 24743680
so i am starting at a step through to try and resolve this problesm the xampp is still runining so i am going to push on and try now to get eclipse running.
I am going to try and find were eclipse is ties in to apache to see if there are different ports that they are locked into or if eclipse needs the ports set as well going to try and set them both to 85 and see if i can get the debuger goign from there
0
 

Author Comment

by:sydneyguy
ID: 24743701
when i try to load the phpinfo page up from the xampp info page to see what the phpinfo actually is then go to the admin page it stills comes up with http://localhost   instead of http://localhost:85 so this is not getting picked up for starters any ideas
0
 

Author Comment

by:sydneyguy
ID: 24743704
apache started still says [port 80] in the control panel of xampp
0
 

Author Comment

by:sydneyguy
ID: 24743778
am now viiewing with tcpview and monitoring whats happening in the background and have add ed the below image to show what is happening when apache started
apache4948.png
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 

Author Comment

by:sydneyguy
ID: 24743787
it show that the system is using port 85 but it still shows 80 in the control panell
0
 
LVL 30

Expert Comment

by:IanTh
ID: 24744114
I think you need to use the host file as well
0
 

Author Comment

by:sydneyguy
ID: 24744188
I have now switched back to port 80 on the httpd.conf  file and completly disabled my protection to see if there is any difference no difference
0
 

Author Comment

by:sydneyguy
ID: 24744217
it will run the apache untill i try to load up the info page then it stops working
0
 

Author Comment

by:sydneyguy
ID: 24744302

below are some error log messages if that helps

[Tue Jun 30 21:40:33 2009] [notice] Child 4696: Child process is running
[Tue Jun 30 21:40:33 2009] [notice] Child 4696: Acquired the start mutex.
[Tue Jun 30 21:40:33 2009] [notice] Child 4696: Starting 250 worker threads.
[Tue Jun 30 21:40:33 2009] [notice] Child 4696: Starting thread to listen on port 80.
[Tue Jun 30 21:40:33 2009] [notice] Child 4696: Starting thread to listen on port 443.
[Tue Jun 30 21:41:31 2009] [notice] Parent: child process exited with status 255 -- Restarting.
[Tue Jun 30 21:42:20 2009] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Tue Jun 30 21:42:20 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jun 30 21:42:20 2009] [notice] Digest: done
[Tue Jun 30 21:42:22 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 configured -- resuming normal operations
[Tue Jun 30 21:42:22 2009] [notice] Server built: Dec 10 2008 00:10:06
[Tue Jun 30 21:42:22 2009] [notice] Parent: Created child process 1232
[Tue Jun 30 21:42:24 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jun 30 21:42:24 2009] [notice] Digest: done
[Tue Jun 30 21:42:25 2009] [notice] Child 1232: Child process is running
[Tue Jun 30 21:42:25 2009] [notice] Child 1232: Acquired the start mutex.
[Tue Jun 30 21:42:25 2009] [notice] Child 1232: Starting 250 worker threads.
[Tue Jun 30 21:42:25 2009] [notice] Child 1232: Starting thread to listen on port 80.
[Tue Jun 30 21:42:25 2009] [notice] Child 1232: Starting thread to listen on port 443.
[Tue Jun 30 21:43:52 2009] [notice] Parent: child process exited with status 255 -- Restarting.
[Tue Jun 30 21:48:03 2009] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Tue Jun 30 21:48:03 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jun 30 21:48:03 2009] [notice] Digest: done
[Tue Jun 30 21:48:05 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 configured -- resuming normal operations
[Tue Jun 30 21:48:05 2009] [notice] Server built: Dec 10 2008 00:10:06
[Tue Jun 30 21:48:05 2009] [notice] Parent: Created child process 3796
[Tue Jun 30 21:48:07 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jun 30 21:48:07 2009] [notice] Digest: done
[Tue Jun 30 21:48:09 2009] [notice] Child 3796: Child process is running
[Tue Jun 30 21:48:09 2009] [notice] Child 3796: Acquired the start mutex.
[Tue Jun 30 21:48:09 2009] [notice] Child 3796: Starting 250 worker threads.
[Tue Jun 30 21:48:09 2009] [notice] Child 3796: Starting thread to listen on port 80.
[Tue Jun 30 21:48:09 2009] [notice] Child 3796: Starting thread to listen on port 443.
[Tue Jun 30 21:49:11 2009] [notice] Parent: child process exited with status 255 -- Restarting.
[Tue Jun 30 21:49:51 2009] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Tue Jun 30 21:49:51 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jun 30 21:49:51 2009] [notice] Digest: done
[Tue Jun 30 21:49:52 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 configured -- resuming normal operations
[Tue Jun 30 21:49:52 2009] [notice] Server built: Dec 10 2008 00:10:06
[Tue Jun 30 21:49:52 2009] [notice] Parent: Created child process 3308
[Tue Jun 30 21:49:54 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jun 30 21:49:54 2009] [notice] Digest: done
[Tue Jun 30 21:49:55 2009] [notice] Child 3308: Child process is running
[Tue Jun 30 21:49:55 2009] [notice] Child 3308: Acquired the start mutex.
[Tue Jun 30 21:49:55 2009] [notice] Child 3308: Starting 250 worker threads.
[Tue Jun 30 21:49:55 2009] [notice] Child 3308: Starting thread to listen on port 443.
[Tue Jun 30 21:49:55 2009] [notice] Child 3308: Starting thread to listen on port 80.
[Tue Jun 30 21:55:13 2009] [notice] Parent: child process exited with status 255 -- Restarting.
0
 

Author Comment

by:sydneyguy
ID: 24744315
I think you need to use the host file as well

were is this found and what is it?? please
0
 

Author Comment

by:sydneyguy
ID: 24744348
this is a clean the error log and go from scratch what is
[Tue Jun 30 22:02:50 2009] [notice] Child 4268: Starting thread to listen on port 443. supposed to do

[Tue Jun 30 22:02:44 2009] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Tue Jun 30 22:02:44 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jun 30 22:02:44 2009] [notice] Digest: done
[Tue Jun 30 22:02:46 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 configured -- resuming normal operations
[Tue Jun 30 22:02:46 2009] [notice] Server built: Dec 10 2008 00:10:06
[Tue Jun 30 22:02:46 2009] [notice] Parent: Created child process 4268
[Tue Jun 30 22:02:48 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jun 30 22:02:48 2009] [notice] Digest: done
[Tue Jun 30 22:02:50 2009] [notice] Child 4268: Child process is running
[Tue Jun 30 22:02:50 2009] [notice] Child 4268: Acquired the start mutex.
[Tue Jun 30 22:02:50 2009] [notice] Child 4268: Starting 250 worker threads.
[Tue Jun 30 22:02:50 2009] [notice] Child 4268: Starting thread to listen on port 443.
[Tue Jun 30 22:02:50 2009] [notice] Child 4268: Starting thread to listen on port 80.
[Tue Jun 30 22:03:32 2009] [notice] Parent: child process exited with status 255 -- Restarting.
0
 
LVL 5

Expert Comment

by:sscotti
ID: 24750316
You might need a little assistance from someone with more experience with this.  I am a Mac person, use MAMP on Mac OS X.  However, the hosts file usually sits in /etc/hosts.  Has a format like:

##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting.  Do not change this entry.
##
127.0.0.1      localhost
255.255.255.255      broadcasthost
::1             localhost

mapping IP to hostname.
0
 

Author Comment

by:sydneyguy
ID: 24752360
well to every ones help i give thanks but have given up on xampp the original idea is i needed eclipes to debug php sites but have now retired xampp and gone over to easyphp load and its working just fine. loaded first time came uo all pages working and now down to try and get eclipes running as it should. so thanks for you help and look for me in the eclipse question area
garry
0
 

Author Closing Comment

by:sydneyguy
ID: 31597740
thanks for you help have given up on xampp gone to easyphp have no more time to muck around thanks any way
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

A list of useful business intelligence software.
Skype is a P2P (Peer to Peer) instant messaging and VOIP (Voice over IP) service – as well as a whole lot more.
This video will demonstrate how to find the puppet warp tool from the edit menu and where to put the points to edit.
Viewers will learn how to use the Hootsuite Dashboard.

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now