Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1793
  • Last Modified:

Html vs plain text emails from Blackberry Pearl (8100)

Hi

We have 3rd party software on our Exchange server that appends a signature to any email.  If the email is in text, the text sig will append.  If the email is in html, the html sig will append.

If I send an email to my work account, the email/sig is in plain text and the plain text sig shows.  If I send an email to my hotmail account, the email appears to be in html as the html sig shows.

Why is this?
0
lrkwalkers
Asked:
lrkwalkers
  • 4
  • 4
  • 3
4 Solutions
 
Iain MacMillanCommented:
as far as i know, all blackberry handsets communicating with a mail server such as Exchange, uses plain text (i have never been able to change this), however, Hotmail is a web based mail service and as such may set its service to only use HTML messaging (to aid embedding of graphics), so any incoming message is automatically converted to HTML no matter what.

best to try and send various emails from the office to Hotmail, one plain, one RTF and one HTML and see how Hotmail handles them.
0
 
-jonny-Commented:
Are emails sent outside of your exchange domain (i.e. the rest of the world) set to be encoded in HTML by default? that's typically the setup of most people's exchange servers.

By default, sending an email from a blackberry will be plain text, unless you're replying or forwarding to a message that has been encoded as html or rich text (in which case the blackberry will preserve the encoding type).
0
 
Iain MacMillanCommented:
usually exchange Outlook environment is set to use Rich Text Format (RTF) by default, for less overhead and formatting issues - especially if you have Office 2007 and IE7 or above, as Word is now the crappy HTML renderer and not IE anymore.

Always best to check your Outlook settings, Tools, Options and Mail Format tab at the top.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
Iain MacMillanCommented:
i have done a bit of digging on this, and it looks like from 4.1 SP5 (4.1.5) and above BES Server, and if your handset has 4.5 OS, you can enable an option manually to allow it to create and receive HTML enabled emails, this can also be done via policy if required.

If, like me, you have a lot of handsets pre-4.5, they will carry-on as normal with plain text emails, until they receive the 4.5 upgrade.  The setting on the handset is under Email options, and Email Settings, at the foot of the page - according to my Bold.

On the BES the policy is under Email messaging policy group, Disable Rich Content Email IT policy - which if disabled, allows individuals to change the setting themselves.  I'm viewing via Bes 5.0
0
 
lrkwalkersAuthor Commented:
Thanks for the replies...I sent an email to Hotmail in the 3 formats.

The plain text email shows in plain text.  The html shows as html but the rich text email appears to be in html.  That is weird then since the BBs send in plain text...unless it is converted at the Exchange level, then the sig is appended then sent as html.

jonny - where is that setting to show the format of external emails?  We have Exchange 2003.
0
 
-jonny-Commented:
What if you send to an external recipient that opens it in outlook? is the message html/text/rtf? you can check by opening the message in outlook, then choosing file -> properties. It will tell you the encoding type.
0
 
lrkwalkersAuthor Commented:
I open my Hotmail emails in Outlook anyway.

The emails sent as html and rich text are both in html.  The one sent as plain text is plain text.

Is there an Exchange setting somewhere that changes the format of external emails?
0
 
-jonny-Commented:
0
 
-jonny-Commented:
It's the "Apply content settings to non-MAPI clients" setting that you want as I believe emails to Hotmail are treated as such, even though you're opening it with outlook (as it's a POP3/IMAP connection). I could be wrong.
0
 
lrkwalkersAuthor Commented:
Hmm, I don't have that checkbox.

Anyway, it's no big deal.  

Thanks for the replies...I'll assign points
0
 
lrkwalkersAuthor Commented:
Actually, just sent another test email from the BB to another external account and it is in html as well, even though I can see in my sent items in Outlook that it is plain text.

Again, no big deal.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now