Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Infragistic UltraWinGrid 8.3: Exception has been thrown by the target of an invocation.

Posted on 2009-06-29
2
Medium Priority
?
1,172 Views
Last Modified: 2013-11-26
Hi, I have a project that worked fin but now I'm opening it and when I go to the designer view of the form that uses a custom control that inherits from the Infragsitic.UltraWinGrid 8.3 then I get the message:

Object reference not set to an instance of an object.
The variable 'ugvGroupageFiles' is either undeclared or was never assigned.
The variable 'ugvShipmentMovementsDetails' is either undeclared or was never assigned.
(those are the UltraWinGrid inheritted controls) until now I never had a problem with this, don't know neither what I did to change that but I'm sure it can be fixed with a little bit of you help.

In VS I get several warnings:

Warning      2      Exception has been thrown by the target of an invocation.            0      0      
Warning      3      The variable 'ugvGroupageFiles' is either undeclared or was never assigned.      C:\Documents and Settings\lven\My Documents\Visual Studio 2008\Projects\NaviTransN\NaviTransNGUI\frmGroupageFiles.designer.cs      222      0      
Warning      4      Exception has been thrown by the target of an invocation.            0      0      
Warning      5      The variable 'ugvShipmentMovementsDetails' is either undeclared or was never assigned.      C:\Documents and Settings\lven\My Documents\Visual Studio 2008\Projects\NaviTransN\NaviTransNGUI\frmGroupageFiles.designer.cs      382      0      
0
Comment
Question by:ACAE
2 Comments
 
LVL 8

Expert Comment

by:Bob Hoffman
ID: 24738274
Do you have more then one version of Infragistic on your machine? If so make sure you don't have reference to multiple versions of Infragistic referenced in your project. I've had issue with this in my Infragistic projects. For some reson the project reference get screwed up.
0
 

Accepted Solution

by:
ACAE earned 0 total points
ID: 24742883
I also thought it was something with the references, but I found the solution.
I was setting certain colors from a XML File in the the constructor, so the VS2008 Designer didn't knew where to get the colors from and threw an error. By setting them in the FormLoad event it was fixed.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Today I had a very interesting conundrum that had to get solved quickly. Needless to say, it wasn't resolved quickly because when we needed it we were very rushed, but as soon as the conference call was over and I took a step back I saw the correct …
How to install Selenium IDE and loops for quick automated testing. Get Selenium IDE from http://seleniumhq.org Go to that link and select download selenium in the right hand column That will then direct you to their download page. From that p…
This tutorial covers a step-by-step guide to install VisualVM launcher in eclipse.
The viewer will learn how to use NetBeans IDE 8.0 for Windows to connect to a MySQL database. Open Services Panel: Create a new connection using New Connection Wizard: Create a test database called eetutorial: Create a new test tabel called ee…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question