?
Solved

Exchange 2007 SP1, Public Folders HTTP/1.1 501 Not Implemented, GFI MailEssentials

Posted on 2009-06-29
6
Medium Priority
?
911 Views
Last Modified: 2012-08-14
When accessing https://servername/public on our Exchange 2007 server, we got error:

HTTP/1.1 501 Not Implemented

When logging in to OWA (https://servername/owa), we can access the public folder (menu bottom-left). From the Outlook Client we also access the Public Folders.

This error needs to be solved, so when can activate Public FolderScanning by GFI MailEssentials. Now this fails, we can't connect throug WebDAV

Any ideas?

Regards,
Jeroen


gfi.png
0
Comment
Question by:J_Zelvoort
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
6 Comments
 
LVL 11

Expert Comment

by:Stephen Croft
ID: 24736290
I would imagine it is because the /public/ URL doesn't exist with Exchange 2007.

I would imagine the setup guide for GFI will guide you as to how to do this (Using WebDAV it may need https://server/webDAV or similar for example), however other EE posts suggest that GFI were late in bringing the PF support in 2007, so check it is actually supported!
0
 

Author Comment

by:J_Zelvoort
ID: 24738015
Hi djxtreme,

GFI should support x2k7, so it sais in its manual... I believe this is not an GFI issue....
Thanks for your reply,
Jeroeb
0
 
LVL 65

Expert Comment

by:Mestha
ID: 24738210
Do you have the /public virtual directory in Exchange? If not then you will need to create it using the following command:

New-OwaVirtualDirectory -OwaVersion:"Exchange2003or2000" -Name "Public" -WebSite "Default Web Site" -VirtualDirectoryType:PublicFolders

Simon.
0
 

Author Comment

by:J_Zelvoort
ID: 24738470
Hi Mestha,
Public Folder is present. (See att.)
Reg,
Jeroen

public-folders.png
0
 
LVL 65

Accepted Solution

by:
Mestha earned 2000 total points
ID: 24746693
I would delete it and then recreate it then.
You need to use the remove-owavirtualdirectory command, do not delete it through IIS manager.

Simon.
0

Featured Post

Is Your AD Toolbox Looking More Like a Toybox?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
The core idea of this article is to make you acquainted with the best way in which you can export Exchange mailbox to PST format.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

718 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question