activesync error on SBS2003

Hi,

I'm facing a problem with a client his activation of push mail.
server running sbs 2003 exchange has sp2

run the connect to internet wizard
I'm able to connect to domain/owa with firefox and login into the account
https://sbs.*.be/Microsoft-Server-Activesync/ is up and running
sbs analyzer tool shows a 100% correct installed server log

i'm unable to connect a nokia device to the server and iphone, tried the testexchangeconnectivity.com website and i got this error:

Test Details
Copy to Clipboard      Expand/Collapse       
      Testing Exchange Activesync for host https://sbs.domain.be/Microsoft-Server-Activesync/
       Exchange Activesync test Failed
      Test Steps
       
      Attempting to Resolve the host name sbs.*.be in DNS.
       Host successfully Resolved
      Additional Details
       IP(s) returned:
      Testing TCP Port 443 on host sbs.domain.be to ensure it is listening/open.
       The port was opened successfully.
      Testing SSL Certificate for validity.
       The certificate passed all validation requirements.
      Test Steps
       
      Validating certificate name
       Successfully validated the certificate name
      Additional Details
       Found hostname sbs.*.be in Certificate Subject Common name
      Testing certificate date to ensure validity
       Date Validation passed. The certificate is not expired.
      Additional Details
       Certificate is valid: NotBefore = 6/29/2009 5:24:43 AM, NotAfter = 6/29/2014 5:24:43 AM
      Testing Http Authentication Methods for URL https://sbs.domain.be/Microsoft-Server-Activesync/
       Http Authentication Methods are correct
      Additional Details
       Found all expected authentication methods and no disallowed methods. Methods Found: Basic
      Attempting an Activesync session with server
       Errors were encountered while testing the ActiveSync session
      Test Steps
       
      Attempting to send OPTIONS command to server
       Testing the OPTIONS command failed. See Additional Details for more info
      Additional Details
       A Web Exception occured because an HTTP 401 - Unauthorized response was received from Unknown


any help would be very appriciated
ads711Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Alan HardistyCo-OwnerCommented:
Have a read of the following link - although the link then forwards you to myspace!:
http://www.chicagotech.net/netforums/viewtopic.php?f=1&t=6123
Suggested details to resolve are:
The issue can be caused by the incorrect IIS settings. First, I suggest running the Configure E-Mail and Internet Connection Wizard. The wizard should help you reconfigure the /Exchange virtual directory and forms-based authentication to work with Outlook Mobile Access and with Exchange ActiveSync. Then restart WinHTTP Web Proxy Auto-Discovery Service and test the issue again

Please also check if you have a Firewall and not allowed a Rule on the Firewall for Microsoft-Server-ActiveSync
http://support.microsoft.com/default.aspx/kb/924216

If the issue persists, please refer to the following KB to reset the default virtual directories

How to reset the default virtual directories that are required to provide Outlook Web Access, Exchange ActiveSync, and Outlook Mobile Access services in Exchange Server 2003

http://support.microsoft.com/kb/883380


0
ads711Author Commented:
Hi Alan,

Tried the steps you provided but still no result result.

Still the same error any thoughts?
0
Alan HardistyCo-OwnerCommented:
  1. Is this a 1st time Activesync setup?
  2. Have you got existing phones working happily?
  3. Is it just these particular phones that are giving you a hard time?
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

ads711Author Commented:
1. yes first time
2. no
3. no i tried it with an iphone, nokia e71 and a htc shift

brgds
0
Alan HardistyCo-OwnerCommented:
If I try to perform an NSLOOKUP on sbs.yourdomain.be I don't see any results.  Is the domain in your post the correct domain?
If it is, then DNS is not setup properly.  If not, then you need to setup a DNS record for SBS on your domain.
Checking the domain you have listed does not show any DNS records for sbs!
0
Alan HardistyCo-OwnerCommented:
Have a read through the following article and check your server is setup as per the instructions:
http://www.amset.info/exchange/rpc-http.asp
For SBS you should follow the single server instructions.
What is your SSL certificate showing?  sbs.yourdomain.be?
0
ads711Author Commented:
hi alan,

the domain name in the post is just a dummy name.

i did a nslookup and got a correct relay

ssl certificate is a Tawnte ssl certificat and shows sbs.*.be
0
Alan HardistyCo-OwnerCommented:
Have you run through the link I gave you to check the server is setup properly?
the sbs.yourdomain.be seems to be working despite me not being able to perform an nslookup on it!
0
Alan HardistyCo-OwnerCommented:
The part you may have missed is the registry entries.
0
ads711Author Commented:
seems to be working  

/rpc give the "correct" error  after prompting for a logn and password

HTTP Error 401.1 - Unauthorized: Access is denied due to invalid credentials.
Internet Information Services (IIS)

0
ads711Author Commented:
The registry keys were allready in the register.

these are the values for validports:

server:593;-server:6001-6002;server:6004;server.domain.local:593;server.domain.local:6001-6002;server.domain.local:6004
0
Alan HardistyCo-OwnerCommented:
Your registry key should look like this:

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\RpcProxy]
"server:6001-6002;
server:6004;
server.domain.local:6001-6002;
server.domain.local:6004;
mail.external.com:6001-6002;
mail.external.com:6004;"

Do you have the external (sbs.yourdomain.be) entries listed as it appears that you don't?
Don't know why you have server:593 as this is not a supported port that I am aware of.
0
ads711Author Commented:
hi Alan,

changed the reg key and removed the 593 port, but still no effect


       A Web Exception occured because an HTTP 401 - Unauthorized response was received from Unknown

brgds



0
Alan HardistyCo-OwnerCommented:
What does the https://testexchangeconnectivity.com site suggest you might do to try and troubleshoot the problem?
0
ads711Author Commented:
nothing there is no additional link

0
Alan HardistyCo-OwnerCommented:
Have you expanded the error tree?  There is usually some hints as to how to troubleshoot.
0
ads711Author Commented:
no,
this is the "log"


Copy to Clipboard      Expand/Collapse      
      Testing Exchange Activesync for host https://sbs.domain.be/Microsoft-Server-Activesync/
       Exchange Activesync test Failed
      Test Steps
       
      Attempting to Resolve the host name sbs.orbolabels.be in DNS.
       Host successfully Resolved
      Additional Details
       IP(s) returned:
      Testing TCP Port 443 on host sbs.domain.be to ensure it is listening/open.
       The port was opened successfully.
      Testing SSL Certificate for validity.
       The certificate passed all validation requirements.
      Test Steps
       
      Validating certificate name
       Successfully validated the certificate name
      Additional Details
       Found hostname sbs.orbolabels.be in Certificate Subject Common name
      Testing certificate date to ensure validity
       Date Validation passed. The certificate is not expired.
      Additional Details
       Certificate is valid: NotBefore = 6/29/2009 5:24:43 AM, NotAfter = 6/29/2014 5:24:43 AM
      Testing Http Authentication Methods for URL https://sbs.domain.be/Microsoft-Server-Activesync/
       Http Authentication Methods are correct
      Additional Details
       Found all expected authentication methods and no disallowed methods. Methods Found: Basic
      Attempting an Activesync session with server
       Errors were encountered while testing the ActiveSync session
      Test Steps
       
      Attempting to send OPTIONS command to server
       Testing the OPTIONS command failed. See Additional Details for more info
      Additional Details
       A Web Exception occured because an HTTP 401 - Unauthorized response was received from Unknown

0
Alan HardistyCo-OwnerCommented:
What happens if you try to visit the link https://sbs.orbolabels.be/Microsoft-Server-Activesync in IE on a local PC?
You should have to logon?
0
ads711Author Commented:
i get a login popup and after i put in the credentials i get a white page with this on it:

HTTP/1.1 501 Not Implemented




0
Alan HardistyCo-OwnerCommented:
That's what I get on my server and my server works.
Have you tried the phones again?
Have you installed the certificate on the phone?
0
ads711Author Commented:
i'm able to connect now, but this is what happens:

i have an empty inbox and and i'm not able to send mails


it seems that the folder "inbox" doesn't sync with the reel folder
0
Alan HardistyCo-OwnerCommented:
On the phone, unplug any USB cables then click on Start, Programs, Activesync.
Click on Menu, Options.
Highlight Exchange Server and click on Delete.
Highlight anything else and click delete.
Then click on Menu, Add server source.
Run through the setup again.
What happens?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ads711Author Commented:
I get this error in the log view of the server

Unexpected Exchange mailbox Server error: Server: [server.domain.local] User: [thomas@domain.be] HTTP status code: [501]. Verify that the Exchange mailbox Server is working correctly.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
0
Alan HardistyCo-OwnerCommented:
Can you check the host headers on the default website and tell me what it says?  Is there a blank entry?
Is the site restricted to a number of connections (performance tab)?
0
ads711Author Commented:
it says default  ip address , tcp port = 80 , host header value is empty

0
ads711Author Commented:
connections limited to 500
0
Alan HardistyCo-OwnerCommented:
Okay, that's fine - how are you getting on with the phones?
0
ads711Author Commented:
still no change, i get into the "inbox" but i can't see no mails
0
Alan HardistyCo-OwnerCommented:
Can you see email if you use IE to access http://sbs.orbolabels.be/exchange ?
0
ads711Author Commented:
yes and also with Firefox i'm able to log into the /owa url



0
ads711Author Commented:
Alan

it works

i followed  all you steps and now i ran the internet configuration wizard and it works

fleww  :)

thx
0
Alan HardistyCo-OwnerCommented:
And do you see the emails?
0
Alan HardistyCo-OwnerCommented:
Hurrah - pesky mobile phones!
Great news - thanks for the points.
Alan
0
ads711Author Commented:
np :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.