Solved

Opening .txt and .pdf's from WebDav folders.

Posted on 2009-06-29
11
844 Views
Last Modified: 2013-12-06
When trying to open .txt or pdf's from all client machines (XP sp2 and sp3, Vista Sp1) you get the following error. "The filename, directory name, or volume label syntax is incorrect' . You can after you get the error use the file menu of the assosiated app (notepad or Acrobat respectively) to do a File->Open->Browse to the file and open it normally.Oddly though you can open any MSOffice file (Word, Excel, PP, Access) with no errors at all. An additional issue is that you cannot double click on any file or directory object ot open them you have to Right Click and select either Explore or Open to open anything. I have spoken with microsoft and they gave me 2 Hotfixs to try but they did not work. I will list the KB's in the code box below. This one is a tough one, any insight would be appreciated.
http://support.microsoft.com/kb/907306

http://support.microsoft.com/kb/943337

Open in new window

0
Comment
Question by:alduduk
11 Comments
 
LVL 11

Expert Comment

by:loftyworm
ID: 24738029
My knee jerk thought is that they may not be files, they may be links, I have seen this before.

Also, I know that Windows will treat files different depending on what folder the reside in, your IE cache folder for instance.  Try coping the offending files to a new location, and then see if you can open them that way, that will confirm if it is a folder location issue.
0
 

Author Comment

by:alduduk
ID: 24738828
I have tried moving the existing files and creating my own files in multiple directories within the WebDav site. Get the same results. You can open all the files, just all txt files  and pdfs have to be accessed from within an application. For example you can just launch Wordpad, Notepad or Word then from within the app do a file->browse to the mapped webdav folders and open .txt files with no problem. But you cannot browse to the webdav folders using explorer and click on the files to open them. If you browse to the webdav folder and right click on the file and choose open off the context menu it launches the associated app and immediately gives you an error dialog "The filename, directory name, or volume label syntax is incorrect'. It only does this with .txt and .pdf's. I have also gone into the webdav server and found that the files behave normally there. And if copied out of the webdav folder to a client machine they behave normally. I hope that this clarifies better whats going on. Thanks for the input.
0
 
LVL 11

Expert Comment

by:loftyworm
ID: 24739173
It does, and I think I might maybe know what is going on, but not sure how to direct you.
I had a similar issue with rdp files, and need to set up the server's MIME types in oder to get the server to allow the client to open up the file with an application, rather then the browser.  I did this inthe MIME type with the entry .rdp  Application/x-rdp.

Now how this reflects on yours, I am not certian.  It seems that the txt and pdf would be defined by default, but maybe something got munged, and it needs to be reset.
0
 

Author Comment

by:alduduk
ID: 24740947
Tried playing with the MiME settings but got no love, but then I was just stabbing in the dark with it. Basically tried changing some of the syntax for the file open statement, changed the DDE settings. Used the restore to default setting but to no avail.
0
 
LVL 11

Expert Comment

by:loftyworm
ID: 24758842
Sorry, I am outa ideas, maybe get a moderator to bump this again.  Sorry
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 

Accepted Solution

by:
alduduk earned 0 total points
ID: 24758908
I appreciate your attempt. I am having a conference call with Microsoft tomorrow morning to see if they can come up with anything else.
0
 
LVL 11

Expert Comment

by:loftyworm
ID: 24872384
What was the answer from MS?

0
 

Author Comment

by:alduduk
ID: 24873567
A combination of permission settings and the setting for allowing scripts and executables.
0
 

Expert Comment

by:CHINOS
ID: 25310760
Hi I have the exact problem, could you specify what settings and permissions had to be changed?  

Also, were you changing these settings on your local security policies or were they on some IIS server?

Thanks
0
 
LVL 1

Expert Comment

by:bitGrok
ID: 26180743
I second CHINOS questions. Could you be more specific on what solved the problem? I am having the exact same issue.

Thanks.
0
 

Author Comment

by:alduduk
ID: 26181011
The answer Microsoft came up with that was actually unacceptable was to not use SSL encryption. With the certificate removed the problem went away. We tried alot of variations trying to get it to work with encryption but never got it working right. We ended up going with a VPN solution and dumping WebDav altogether. Sorry if this dosn't help. It was a very long and frustrating battle with Microsoft trying to figure this out. In the end they still had not conceeded that there was a problem with WebDav that couldn't be fixed, but my client had run out of patience and I had to find a different solution or lose the client.
0

Featured Post

Get up to 2TB FREE CLOUD per backup license!

An exclusive Black Friday offer just for Expert Exchange audience! Buy any of our top-rated backup solutions & get up to 2TB free cloud per system! Perform local & cloud backup in the same step, and restore instantly—anytime, anywhere. Grab this deal now before it disappears!

Join & Write a Comment

Over the past decade, as Internet security has become a chief concern of IT professionals, one of the most common questions administrators and users ask is, “Which is more secure, SFTP or FTPS?” In short, both file transfer protocols offer a high…
Outsource Your Fax Infrastructure to the Cloud (And come out looking like an IT Hero!) Relative to the many demands on today’s IT teams, spending capital, time and resources to maintain physical fax servers and infrastructure is not a high priority.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now