Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

OSPF to BGP Routing Problem

Posted on 2009-06-29
4
Medium Priority
?
766 Views
Last Modified: 2012-05-07
Hello,
I am wondering if someone can help me out with a routing problem.
Router (A) is sending /24 routes to router (B) via OSPF. Once (B) gets the routes, it redistributes them into BGP and propagates them throughout our network, no problem.

We just got a /20 network that we are trying to send from (A) as well as our existing /24 routes. What is happening is that (A) is sending the /20 route to (B), we see that (B) is receiving the route via OSPF but for some reason it is not getting propagated via (B)'s BGP.  

However, when we break down the /20 into discrete /24 blocks, we can propagate those no problem.

When I do a show route command from router B, the /20 shows up as follows:

ROUTER(B) #show ip route 192.168.176.0
Routing entry for 192.168.176.0/20, supernet
  Known via "ospf 1", distance 110, metric 20, type extern 2, forward metric 1
  Redistributing via bgp 1
 
And a show route for a working /24-

ROUTER(B)#show ip route 192.168.231.0
Routing entry for 192.168.231.0/24
  Known via "ospf 1", distance 110, metric 20, type extern 2, forward metric 1
  Redistributing via bgp 1



Can someone take a look at the config below? Thanks!


********ROUTER A:********
 
router ospf 1
 router-id 10.10.10.253
 log-adjacency-changes
 redistribute connected subnets
 network 10.10.10.248   0.0.0.3 area 0
 network 10.10.10.253  0.0.0.0 area 0
 
!
ip classless
!
 
********ROUTER B********
router ospf 1
 router-id 10.10.10.254
 log-adjacency-changes
 redistribute connected subnets
 network 10.10.10.248 0.0.0.3 area 0
 network 10.10.10.254 0.0.0.0 area 0
 default-information originate
 
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 bgp confederation identifier 1
 bgp confederation peers 2 3 4
 aggregate-address 10.10.10.0 255.255.255.0 summary-only
 redistribute connected
 redistribute static
 redistribute ospf 1
neighbor 10.10.9.1 route-map CORE out (let's call this router C) 
no auto-summary
 
route-map CORE permit 20
match ip address prefix list 199
set metric 100
set origin igp 
set community no-export
 
********THESE ARE THE /24 routes and the new /20 route********
ip prefix-list 199 seq 5 permit 192.168.231.0/24
ip prefix-list 199 seq 10 permit 192.168.238.0/24
ip prefix-list 199 seq 15 permit 192.168.239.0/24
ip prefix-list 199 seq 20 permit 192.168.241.0/24
ip prefix-list 199 seq 25 permit 192.168.237.0/24
ip prefix-list 199 seq 30 permit 192.168.240.0/24
ip prefix-list 199 seq 35 permit 192.168.229.0/24
ip prefix-list 199 seq 40 permit 192.168.230.0/24
ip prefix-list 199 seq 45 permit 192.168.234.0/24
ip prefix-list 199 seq 50 permit 192.168.233.0/24
ip prefix-list 199 seq 55 permit 192.168.232.0/24
ip prefix-list 199 seq 60 permit 192.168.236.0/24
ip prefix-list 199 seq 65 permit 192.168.235.0/24
ip prefix-list 199 seq 70 permit 192.168.176.0/20

Open in new window

0
Comment
Question by:Northtech
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 29

Expert Comment

by:Jan Springer
ID: 24738444
sh ip bgp neigh 10.10.9.1 adv

with the /20 configured.
0
 

Author Comment

by:Northtech
ID: 24738521
It isn't advertising it, and when I do a "show ip bgp" command it doesn't show up there either

ROUTER(B)#show ip bgp neighbors 10.10.9.1 advertised-routes
BGP table version is 4064, local router ID is 10.10.10.254
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
r>i192.168.229.0    10.10.10.253         100    100      0 i
r>i192.168.230.0    10.10.10.253         100    100      0 i
r>i192.168.231.0    10.10.10.253         100    100      0 i
r>i192.168.232.0    10.10.10.253         100    100      0 i
r>i192.168.233.0    10.10.10.253         100    100      0 i
r>i192.168.234.0    10.10.10.253         100    100      0 i
*> 192.168.235.0    0.0.0.0                  0         32768 ?
r>i192.168.236.0    10.10.10.253         100    100      0 i
r>i192.168.237.0    10.10.10.253         100    100      0 i
r>i192.168.238.0    10.10.10.253         100    100      0 i
r>i192.168.239.0    10.10.10.253         100    100      0 i
r>i192.168.240.0    10.10.10.253         100    100      0 i
r>i192.168.241.0    10.10.10.253         100    100      0 i
*> 10.10.10.0     0.0.0.0                            32768 i

Total number of prefixes 14
0
 
LVL 29

Accepted Solution

by:
Jan Springer earned 2000 total points
ID: 24738774
With the /20 being advertised from A to B, what is the output of the below commands on the B router:

sh ip rou 192.168.176.0

sh ip ospf data | i 192.168.176

And, is the /20 nailed down on the A or B router as a static route or ip address on an interface?  If not, you will have to add the command "network 192.168.176.0 0.0.15.255 area 0" in the OSPF config of the applicable router.
0
 

Author Comment

by:Northtech
ID: 24739064
Jesper, thanks for your help! We just got it working by adding it  statically in the BGP configuration of router B.

The /20 is nailed down as an ip address on an interface of router A.

Now it is advertising via bgp. Before adding this line to router B's config

router bgp 1
network 192.168.176.0 mask 255.255.240.0

It was redistributing to BGP but not advertising



0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this tutorial I will show you with short command examples how to obtain a packet footprint of all traffic flowing thru your Juniper device running ScreenOS. I do not know the exact firmware requirement, but I think the fprofile command is availab…
How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question