• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 592
  • Last Modified:

Two networks connecting with route add

My father has a small company. Owner internet provider (Belgacom) has put a Speedtouch 608 router that we count not manage. He has Ip-address mask DHCP is disabled and the range is set from till To be able to connect more than 4 PC's I have bought a seconde router a belkin 4000df. I have set the wan ip as and the lan ip as mask, DHCP is enabled and the firewall is disabled.
The problem is that the computers on the first router can not connect to the computers on the second router.
Ex. PC1 with ip address PC2 with ip-address A ping on PC1 to PC2 gives a time-out.
So I add a route on PC1: route add mask metric 2. The ping is still not working and with tracert I see no route.
What must I do do so PC1 can ping (connect) to PC2?
Thanks a lot
1 Solution
I think your problem is the speedtouch router that you cannot manage does not have a known route to your belkin.  It only knows about the IP address it has given the belkin and nothing beyond it.  Either somehow get the person who manages the speedtouch to put in a route, or move everything to the belkin (buy a bigger switch if needed)
Robert Sutton JrSenior Network ManagerCommented:
As stated above if possible put all your PCs on your Network(the belkin router). Create your own LAN on the 192.168.1.xxx network. All PCs will use this as its gateway( and enable DHCP. Assign the Belkin Wan interface an Ip of  That way you can manage YOUR own Lan and all devices connected to it. Once every PC is connected to your Lan set all PCs NIC cards to DHCP(Obtain Ip add. Automatically). Depending on the NAT capability of the Belkin, this should be fine for you. If you cannot route to the Internet you may have to add a "Static" route from one network to the other.
IE:  ===> to the

Hope this helps.
I think the issue is that if the packet did not originate from the 192.168.2.x machine than there will not be a NAT translation in the table to route back to. So even by setting a static route to the packet arrives at that point and does not know how to reverse back any further so it forwards along to it's default gateway of and that router does not know what to do with it. Adding a route for 192.168.2.x to on the Belgacom router I believe would just create a loop between the two ip's until it timed out.

I think you will need to setup a static route on the  Belkin device so that it know to forward requests for 192.168.2.x to the internal interface.

If my theory is correct I believe that you should be able to ping from the 192.168.2.x network to the 192.168.254.x network since this will create an entry in the NAT table.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

7 new features that'll make your work life better

It’s our mission to create a product that solves the huge challenges you face at work every day. In case you missed it, here are 7 delightful things we've added recently to monday to make it even more awesome.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now