We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Asterisk one way audio, outbound calls, only on phones sharing LAN with asterisk

Medium Priority
1,443 Views
Last Modified: 2013-11-12
I am getting one way audio with a Linksys spa942, that is on the same LAN as asterisk.  The one way audio, seems to be only on outbound calls.  And the audio that is heard, is what is coming from the SPA942.  The inbound audio to the SPA942, is not heard.

II have about 15 phones across the WAN, that use the same asterisk server, but they have no audio issues.  I have tried pointing the phone to the internal private ip address of asterisk, as well as the external public ip address.

I have port 5061 forwarded to the phone, and the phone set to register and listen on 5061.  Asterisk is listening on 5060 and port 5060 is forwarded to asterisk.  I have udp & tcp ports 10000-20000 forwarded to asterisk.  

I am using a new Netgear FVS338 firewall, NAT enabled, with the second to latest firmware 3.0.4-19.  The most recent firmware 3.0.5-29 has issues with SIP.  This firewall replaced a Netgear FVS114, which is a small firewall, and one of their older models, which for me had zero problems, except it lacked throughput above 5mbps.  Like I said, the FVS114 had no audio problems.

I have sip_nat.conf and sip.conf, configured with
nat=yes
externip = 75.xxx.xx.xx
localnet = 192.168.0.0/255.255.255.0

Any ideas?
Comment
Watch Question

Information Services Manager
CERTIFIED EXPERT
Commented:
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview
Ron MalmsteadInformation Services Manager
CERTIFIED EXPERT

Commented:

Author

Commented:
I do not have the command listed at all.  What is the default, if not listed?
Ron MalmsteadInformation Services Manager
CERTIFIED EXPERT

Commented:
canreinvite is an option in the SIP peer definitions..

It basically tells Asterisk if the phones are allowed to have direct RTP setup (phone to phone or phone to "provider"), rather than Asterisk staying in the media path.  I believe the default is yes, and in a NAT situation this could be problematic.

You are using a sip provider, correct ?

Author

Commented:
I set canreinvite=no and all issues resolved!!!!!!!!!!!!!!!  Thanks xuserx!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Ron MalmsteadInformation Services Manager
CERTIFIED EXPERT

Commented:
Glad to help.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.