Solved

How do I adjust the attachment size limit for Outlook Web Access 2007?

Posted on 2009-06-29
58
2,482 Views
Last Modified: 2012-05-07
Hello, I have been trying to adjust the OWA file attachment size limit for a few days now.  I know the default limit is 10 MB.  I have been trying to raise that limit to 50 MB with no success.  Per ms exchange forums, I tried the following:

- Edited web.config and changed MaxRequestLength to 50000 (50 MB).  All that seemed to do was now give a 404 file not found error while attaching a larger file.

- In Exchange Powershell, I ran Set-mailbox -id:"username" -MaxSendSize:50000.  I used my account to test it with.  This also had no effect.

- In Powershell, I also tried Set-transportconfig -MaxSendSize: 50000 .  This too had no effect.

- Per instructions on the ms exchange website, I restarted the Store.exe service after each change above so that the changes would apply immediately.  Still, the 404 error occurred.

One user suggested looking at the IIS7 logs to determine the problem, but I cannot find the logs either, nor can I understand why this limit change is so difficult to do.

There was also mention of changing the MaxSubmitMessageSize which is readonly and defaults to 10 MB.  I have no idea how to change this either or where the setting is.

Lastly, the clients are mac/win and are using Outlook Web Access light.  Thanks in advance for your help.
0
Comment
Question by:bigeven2002
  • 27
  • 19
  • 6
  • +1
58 Comments
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24740227
Have a read through this article which should answer your question for you:
http://searchexchange.techtarget.com/tip/0,289483,sid43_gci1302783,00.html
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 24742744
Yes I did, this was one of the 3 articles that I reviewed and tried.  It did not work.  While I'm at it, the other 2 articles that I tried are:

http://msexchangeteam.com/archive/2006/11/14/431477.aspx
http://technet.microsoft.com/en-us/library/aa996835.aspx

The solutions on both did not work either.  If it makes a difference, this is Exchange 2007 SP2 with Update rollup 8 running on Windows Server 2008 SP2.  It seems the articles above focus on Exchange 2007 SP1 which I don't know if it matters or not.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24742908
Extract from http://www.fots.nl/index.php/archive/category/exchange/exchange-2007/
 
When you want to adjust the Maximum Attachment Size in Exchange 2007, you can use this script to check where the size limits are set.
The only Message Size limit that is not set through Powershell, is the one for Outlook Web Access.
This is done through the web.config file on the Client Access Server.
First make a backup of the web.config file (default location c:\Program Files\Microsoft\ExchangeServer\ClientAccess\Owa).
Open the file with Notepad Change the line <httpRuntime maxRequestLength=300003 />
Where 30000 is the maximum message size (in kilobytes) Save the file (nothing else needs to be done)
Alternatively, have a read of this previous EE question:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_22656617.html
This is different to the links you have tried (as long as I am reading it correctly).  Hope this gets you there.  Does seem to be inconsistent as to where tou have to set it!
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 24754251
Ah I remember that EE article, I did read that as well and it also referenced one of the articles I mentioned above.  That EE article applied to Exchange 2003.  But I did try one of the suggestions which was setting the limit to an actual number (50 MB) instead of blank or 0 in the management console.  Still no good.

I did modify the web.config file to increase the request length number as indicated in my initial post.  I set it as 500000 (yes 500 MB), and it still did not work.  I had to modify the permissions of the file so I could change it as domain admin.  After testing it, any attachment above 5 MB throws the 404 error.  So 4 MB and lower will attach just fine.

I am unclear on how the fots script works, do I paste that into powershell or save it as a file with a particular extension and run it?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24758570
I don't know how to run the FOTS scripts but this seems to be all it is doing in the Exchange Shell:

Get-transportconfig MaxReceiveSize
 
Get-transportconfig MaxSendSize

Get-receiveconnector Server  MaxMessageSize
 
Get-SendConnector HomeMTA MaxMessageSize
 
Get-TransportServer ExternalDsnMaxMessageAttachSize
 
Get-TransportServer InternalDsnMaxMessageAttachSize
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 24760733
Here is the results of each command indicated above.  Apparently they do not work.

[PS] C:\>Get-transportconfig MaxReceiveSize
Get-TransportConfig : A parameter cannot be found that matches parameter name '
MaxReceiveSize'.
At line:1 char:20
+ Get-transportconfig  <<<< MaxReceiveSize
[PS] C:\>
[PS] C:\>Get-transportconfig MaxSendSize
Get-TransportConfig : A parameter cannot be found that matches parameter name '
MaxSendSize'.
At line:1 char:20
+ Get-transportconfig  <<<< MaxSendSize
[PS] C:\>Get-receiveconnector Server  MaxMessageSize
Get-ReceiveConnector : A parameter cannot be found that matches parameter name
'MaxMessageSize'.
At line:1 char:21
+ Get-receiveconnector  <<<< Server  MaxMessageSize
[PS] C:\>Get-SendConnector HomeMTA MaxMessageSize
Get-SendConnector : A parameter cannot be found that matches parameter name 'Ma
xMessageSize'.
At line:1 char:18
+ Get-SendConnector  <<<< HomeMTA MaxMessageSize
[PS] C:\>Get-TransportServer ExternalDsnMaxMessageAttachSize
Get-TransportServer : The operation could not be performed because object 'Exte
rnalDsnMaxMessageAttachSize' could not be found on domain controller 'domain'.
At line:1 char:20
+ Get-TransportServer  <<<< ExternalDsnMaxMessageAttachSize
[PS] C:\>Get-TransportServer InternalDsnMaxMessageAttachSize
Get-TransportServer : The operation could not be performed because object 'Inte
rnalDsnMaxMessageAttachSize' could not be found on domain controller 'domain'.
At line:1 char:20
+ Get-TransportServer  <<<< InternalDsnMaxMessageAttachSize
[PS] C:\>

Perhaps it's impossible to change the attachment size limit?
0
 
LVL 4

Expert Comment

by:kenzacm
ID: 24760744
Hi There,
You need to remember  when changing the Maximum attachment size you also need to adjust the timeout settings.

Very similar to PHP if you increase your file size from 2MB to 60MB and leave the timeout at 30 seconds, i dont think anyone can attach a 60MB file in less than 30 seconds.

so have a look for a variable in the configs to max execution time or timeout :D
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 24766896
Hi kenzacm, that brings up a good point on the execution time.  Surprisingly none of the articles above talk about increasing that.  I found an MS article that describes adding the executionTimout parameter to the httpRuntime tag and set it to 3600 (1 hr) here:

http://www.websupergoo.com/helpupload50/source/2-tech_notes/3-web.config.htm

I added that and saved the web.config file and logged back into OWA.  However, it did not fix the problem.  I timed the attach operation in OWA by using a 9 MB file, after 7 seconds it throws the 404 error.  So I'm not sure if the timeout is hard set at 7 seconds somewhere or that was just based on upload speed and reaching the mystery limit.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24766948
Not that I am an Exchange 2007 guru (yet!) but have you tried setting those parameters.  If they don't exist this could be your problem as the defaults could be too low, try:
Set-transportconfig MaxReceiveSize
 
Set-transportconfig MaxSendSize

Set-receiveconnector Server  MaxMessageSize
 
Set-SendConnector HomeMTA MaxMessageSize
 
Set-TransportServer ExternalDsnMaxMessageAttachSize
 
Set-TransportServer InternalDsnMaxMessageAttachSize
Alan
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 24788536
Sorry for the delay, I will try this tonight and report back.
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 24791907
Didn't realize the command was case sensitive:

[PS] C:\>Set-transportconfig MaxReceiveSize 50 MB
Set-TransportConfig : A parameter cannot be found that matches parameter name '
MaxReceiveSize'.
At line:1 char:20
+ Set-transportconfig  <<<< MaxReceiveSize 50 MB
[PS] C:\>Set-transportconfig MaxReceiveSize 50MB
Set-TransportConfig : A parameter cannot be found that matches parameter name '
MaxReceiveSize'.
At line:1 char:20
+ Set-transportconfig  <<<< MaxReceiveSize 50MB


OK now trying it again:

[PS] C:\>Set-TransportConfig -MaxSendSize 50MB
WARNING: The command completed successfully but no settings of 'Transport
Settings' have been modified.
[PS] C:\>Set-TransportConfig -MaxReceiveSize 50MB
[PS] C:\>Set-TransportConfig -MaxReceiveSize 50MB -MaxSendSize 50MB
WARNING: The command completed successfully but no settings of 'Transport
Settings' have been modified.
[PS] C:\>Set-TransportConfig -MaxSendSize 50MB
WARNING: The command completed successfully but no settings of 'Transport
Settings' have been modified.
[PS] C:\>

So now the command completes but doesn't do anything?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24792007
Sorry - cannot offer any more suggestions - I will ask for a moderator to call on other experts to assist you.
Good luck - Alan
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 24832970
If it helps any, the settings tried above work for regular Outlook 2007, but have no effect on Outlook Web Access.
0
 
LVL 4

Expert Comment

by:kenzacm
ID: 25162033
have you looked for a config file for OWA under IIS? as in what has the details for exchange server
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 25164619
I have.  I found the web.config file in the exchange owa folder as per the instructions.  I changed it to allow an increased file size accordingly, but the changes did not work.
0
 
LVL 4

Expert Comment

by:kenzacm
ID: 25167850
did you restart IIS afterwards?
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 25178580
Yes, I also rebooted the entire server as well.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 25265345
I am sure that the question is answereable, but you may have to call Microsoft to get the answer (which may have already been provided) and to implement it as it may be you have a configuration problem preventing it from working.
Either way - sorry you don't have the answer so far and I hope you get there one way or another.
Alan
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 25267093
I know you have started the close on this question, can you confirm that it is when you are trying to uplad the file not when you are sending it that is causing the problem?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 25267184
Lets keep this one open a little while longer and we will see if we can get this one resolved for you.
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 25267659
Hi demazter, correct, the 404 error occurs during the upload process of the attachment, not during the sending process.  thanks for the support so far everyone!
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 25268888
and you are getting this 404 error for anything over 10MB?
Is the exchange server running on Windows 2003 or 2008?
What do you have in between the exchange server and the internet?

I have just uploaded a 23MB file to OWA Light on a vanilla install of Exchange 2007 on Win2008, which leads me to believe it could be your router/firewall that has a session timeout on it?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 25268903
You could also check the IIS log files which may give us a little more information, in 2008 they are in:
%systemdrive%\inetpub\logs\logfiles

in 2003 they are in: %windir%\System32\LogFiles\
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 25269225
Anything above 9 MB is giving the 404 error.  It is on Server 2008 Enterprise and there is Websense Proxy between Exchange and the Internet.  However, we are accessing OWA inside our network so the operation never reaches the Proxy or the Firewall/Router.  I'll check the logs asap, is there any specific criteria I should look for?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 25269240
Just looking for any type of error that might help at the moment.

Out of interest if you remove the proxy from one client machine and try the same thing what happens?
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 25272408
Not sure how.  The proxy is it's own server and the MX entries for DNS point to it instead of the actual Exchange server.  The proxy forwards incoming email to Exchange after it has been filtered.  So the proxy itself is not installed on the client machines per se.

But one thing I did do though, I did a test send through OWA Full (not light) and attached a 2 MB file.  It took 38 seconds to send, but worked.  I then tried to attach a 9 MB file and send, and after 7 seconds, it threw the 404 error.  both tests were done on my home pc (off the network).

So it appears that it is not a timeout issue, but an attachment size issue.  I checked the web.config file again and it is set to 50000 for max file size (50 MB).

0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 25272837
On the client machines in Internet explorer if you goto tools > Internet options > connections > LAN settings

is there a proxy address entered here? If so remove it restart Internet explorer and open owa by going to https://servername/ow ( do not use it's Internet address)

exchange 2007 does not behave in this way by default so there must be something else causing the problem.  Is Websense running on ISA? I'd so is it 2004 or 2006?

Another test would be to logon to the exchange server via Remote Desktop or the console (remove any proxy settings from Internet explorer as before) and then launch https://localhost/owa and try uploading an atatchment this will help us to eliminate the exchange server as being the problem.
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 
LVL 74

Expert Comment

by:Glen Knight
ID: 25272938
Which service pack level of exchange are you using?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 25273045
It appears this may be one of the new "features" of SP1 - I am doing some tests in my lab and will report back.
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 25287243
Hi demazter:

Websense is running on IIS 6 (Server 2003 R2 SP2), client machines do not have any proxy configs under LAN settings in Internet Options and the auto detect proxy settings is unchecked.

Exchange server is 2007 SP1 with Update Rollup 9 running on Server 2008 SP2, under about in the console version is: 8.01.0375.002.  I am unsure when this problem started happening, it was a client who brought this to my attention a few months back when she couldn't attach large files.  The initial file was way less than 30 MB which was supposed to be the default, but the 404 occurred ever since.

Per your request I did also try going through OWA with the NetBIOS name instead of the FQDN.  Same result, I tested an 8 MB file and it threw the 404.  This was on OWA full with IE.

I'm beginning to agree that SP1 did break this functionality.  Any changes to this point with web.config and all have had no effect.

0
 
LVL 17

Author Comment

by:bigeven2002
ID: 25287264
One thing I should mentioned, a correction, when this was first brought to my attention by the client, it was not a 404 error, but OWA actually stated that the attachment exceeded the maximum size allowed.  The initial attachment was 11 MB.  At the time, the web.config limit was 30 MB and I changed it to 50 MB.  That was when the 404 issue started.  I reverted it back to 30 MB but even then it still thew the 404.  So right now it is 50 MB.

Someone on an exchange support page mentioned a hard limit of 10 MB in OWA but they did not explain how to modify it.  But it appears to override the web.config file if that's the case.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 25287323
just to confirm if you navigate to c:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa
edit the web.config file (be sure not to change the extension of this file) and look for the value:
<httpRuntime maxRequestLength="30000" /> and change the 30000 to 50000

Then in the Exchange Management Console you run the following:

Set-transportconfig -MaxSendSize: 50000

Then restart the store
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 25287429
You might also want to run the following against the user your experiencing problems with.  If changes have been made in the past they may be being picked up before the transport rule setting:

Set-mailbox -id:"username" -MaxSendSize:50000
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 25289463
Actually performed both actions there.  Changed the web.config maxsendsize, that's what I meant by changing it from 30 MB to 50 MB (30000 to 50000), and also tried the transportconfig and set mailbox commands.  those were among the first I tried.  No effect unfortunately.  However, using regular Outlook 2007, the change works fine when I tested it.  It just doesn't work in OWA.

One thing I had to do though to modify the web.config file was to change the permissions to the file where domain admins had modify permissions.
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 25289471
Oops, forgot to add, yes I did restart store.exe as well

net stop store.exe
net start store.exe

Also rebooted the entire server too.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 25289472
And you have tried the exact commands I posted?
In the previous posts 50MB was specified and there was no - before the MaxSendSize
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 25297875
Yes, I did the Set-mailbox -id:"username" -MaxSendSize:50000 with my own email account as a test, it only works in Outlook, it will not work in OWA.  I probably made a typo in previous posts but Exchange showed that the command completed successfully when I tried this.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 25297893
Can I suggest running the Exchange Best Practice Analzer (In Exchange Managament Console highlight Microsoft Exchange the click the link for Best Practice Analyzer) and see if there are any suggestions in here.
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 25297986
Ok I just tried it again.  I made sure 50000 was in web.confg, ran Set-transportconfig -MaxSendSize: 50000, and restarted store.exe.  

Now the thing is hosed.  I can't attach anything now.  Instead of setting the maxsendsize limit to 50000 like it was supposed to, now it's 0 for everyone in both Outlook and OWA.  WTF?!
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 25298013
I ran this command:

get-transportconfig | fl maxrecievesize,maxsendsize

It shows MaxSendSize: 49 KB

How do I fix this?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 25298039
run get-transportconfig -maxsendsize:50MB
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 25298043
sorry typo, should read set-transportconfig -maxsendsize:50MB

I just have done this on my Exchange 2007 and then run the get command and it is now 50MB
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 25298087
Try setting it to something rediculous like:

set-transportconfig -maxsendsize:100MB
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 25298101
Ok got it, even though it shows 50MB now, outlook still says attachment limit exceeded.  This was with a 1.4 MB file
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 25298105
you restarted the store and IIS etc?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 25298112
There is also the Transport Service you may need to restart, it might be worth restarting all the exchange services and IIS
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 25298143
heck, I just rebooted the entire server.  There was critical updates to install anyways.

I got the send size straightened back out, but my account was still !@#$ up.  I re-did your command from earlier:

Set-mailbox -id:"me" -MaxSendSize:50000

Except this time I changed it to:

Set-mailbox -id:"me" -MaxSendSize:50MB

As soon as the server reboots, I'll check it.  but otherwise, I am back where I started, and that is with a 404 error on a 9 MB attachment.
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 25298195
ok it's back up now and the attachment limit on my account is fixed.  So we are officially back to where we started.  In outlook I was able to attach a 9 MB file perfectly, but in OWA, it still shows the 404 error.

When is SP2 going to be out?
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 25298198
I'll be in touch tomorrow.  Thanks!
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 25298201
I wonder if the web.confg file setting is in bytes?

Try adding an extra 2 zero's on the end.
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 25298210
Actually, I did try 50000000, but no effect.
0
 
LVL 74

Accepted Solution

by:
Glen Knight earned 500 total points
ID: 25298236
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 25300365
Before I proceed with it, is there any issues I should look out for on SP2?
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 25419086
I am going to try and install SP2 next weekend.  thanks
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 25474348
Sorry everyone for the wait, the problem has been fixed!  The solution was installing service pack 2.  Along with other fixes it also fixed the 404 error on OWA attachments.  Thanks everyone for all the suggestions.
0

Featured Post

Do email signature updates give you a headache?

Do you feel like all of your time is spent managing email signatures? Too busy to visit every user’s desk to make updates? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today!

Join & Write a Comment

Sometimes Outlook might have problems sending a message. There may be various causes- corrupted PST, AV scanner etc. The message, instead of going to the Sent Items folder, sits in the Outbox indefinitely. To remove it you can use a free tool cal…
Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
The viewer will learn how to create two correlated normally distributed random variables in Excel, use a normal distribution to simulate the return on different levels of investment in each of the two funds over a period of ten years, and, create a …
how to add IIS SMTP to handle application/Scanner relays into office 365.

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now