Must enable Outlook add-ins with every image activation

Win XP SP3, Outlook 2007 in MS Office 2007 Ultiimate, Exchange on SBS 2003
I do not have this problem on my laptop which I try to keep configured the same as my desktop.
Desktop - Dell Dimension 4500, Laptop Dell Latitude D600.  The problem is also not seen on other clients in the domain.

Every time I launch Outlook I get several security notices telling me of add-ins that have been disabled.  I click on the "Enable application add-in" button and all is well until the next time I launch Outlook.  If I look at the add-ins in the Trust Center I find that they are all enabled as expected.  

If instead of clicking on the enable button I click on the disable buttton and then try to activate them through the Trust Center it doesn't help.

How can I convince Outlook that I really do want them enabled every time without having to say so every time?
qsysllcAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnmenZCommented:
Outlook 2007 looks at HKCU\Software\Microsoft\Office\Outlook\Addins\AddinName\LoadBehavior to determine if the addin is enabled or not.  that registry key is part of your user profile.  Reasons that the setting didn't get saved include:

1. Outlook have problem changing the registry key value from "2" (disable" to "3" (enabled".  You can run the Process Monitor (Sysinternals tool) to find out if that is the case

2. Outlook is able to save the setting, but the profile didn't survive to the next logon.  You are not using roaming profile, aren't you?  Is there any setting in place that may cleanup your profile?  Also to ensure you are not using a temporary profile which doesn't get saved upon log off.
0
qsysllcAuthor Commented:
Thank you for the info.  The LoadBehavior was set to 3 for all of the add-ins I have enabled.  I logged out, to save my roaming profile, logged in again and confirmed the settings were still "3".  I started Outlook and it prompted me for each of them so I clicked on the enable for each one.

I started Outlook again and when prompted selected "disable" for each of the add-ins.  I confirmed in the Trust Center that they were disabled but the "LoadBehavior" settings were still all "3".  I shutdown Outlook, restarted it and again got prompted to enable each of the add-ins..
0
JohnmenZCommented:
Do you know if the addin has any issue itself?  Is it working fine on your laptop?

This link may be helpful, have a look:
http://blogs.msdn.com/vsod/archive/2008/04/22/Troubleshooting-com-add-in-load-failures.aspx

Another more complex way to find out if Outlook honours the LoadBehavior key value is to run the Process Monitor from Sysinternals.com, and see what Outlook does in terms of reading registry keys.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

qsysllcAuthor Commented:
It was working fine on the laptop for several weeks while the problem was present on the desktop.  For some reasons not related to this problem I had to remove the laptop from the domain and delete my profile on the laptop.  When I added it back into the domain and logged in the problem existed on the laptop so I suspect it's something in my domain profile.  There are 5 add-ins that are requiring enabling each time: Apple's Outlook Change Notifier, Google Desktop, Itunes, SmartWhoIs, SpamBayes.  If I manually change the LoadBehaviors to "2" they do not load and do not prompt.  If I change them to "3" they prompt for enabling.  

I looked at the link you provided.  I didn't find anything that helped but that doesn't guarantee anything since I'm not a developer.
0
JohnmenZCommented:
Two more things to try:

1. In Outlook, when you go to "help" menu -> "Disabled Items...", you should see those addins, do you?  Enabling them from there doesn't make any difference?

2. Try login as a newly created local user, not a domain user, which will give you a new user profile.  Then run the Outlook to connect to your domain mailbox, see if the addins are still prompting?  Also you can try enabling them from this local acocunt and see if they will prompt you in next Outlook run?
0
qsysllcAuthor Commented:
Problem solved.  Although you didn't hit the nail on the head your assistance led me to the solution so you will get the points for the help.

In setting up the new profile as you suggested in "2" above I noticed a difference in the configuration from the way my account was set up.  In the "add-ins" page of the "Trust Center" on my account there was a check in te box labelled "Apply macro security settings to installed add-ins".  I removed the check mark and the problem is resolved.  I confirmed it on my laptop.  Thank you for the assistance.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Office

From novice to tech pro — start learning today.