Elastix/Asterisk not open on port 5060

I've recently setup Elastix, and setup extensions, etc - however when it comes to having Cisco IP phones, and a SIP Soft phone connecting to the Elastix box, it doesn't work. I was pulling my hair out trying to figure out what it was, but ended up checking if the port was actually open by telneting to it, and checking if the port was open on the server, and found out port 5060 was not open on the server:

[root@pbx asterisk]# lsof -i:5060
[root@pbx asterisk]#

[root@pbx asterisk]# netstat -napt | grep asterisk
tcp 0 0 0.0.0.0:5038 0.0.0.0:* LISTEN 8704/asterisk
tcp 0 0 127.0.0.1:5038 127.0.0.1:56084 ESTABLISHED 8704/asterisk
[root@pbx asterisk]#

[root@pbx asterisk]# netstat -napt | grep 5060
[root@pbx asterisk]#

I've restarted Asterisk several times via the command line, as well as reboot the entire server, but I'm not sure how to get it to listening on port 5060 so our Cisco 7960s can connect to it.

Does anyone know how I can fix this?
crucialxAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ron MalmsteadInformation Services ManagerCommented:
Which OS is this ?...are you running SELinux ?
0
crucialxAuthor Commented:
I used the ISO from the Elastix website, 64bit: http://downloads.sourceforge.net/elastix/Elastix-1.5.2-stable-x86_64-bin-31mar2009.iso

From dmesg, it appears SELinux is not running:

SELinux:  Initializing.
SELinux:  Starting in permissive mode
selinux_register_security:  Registering secondary module capability
SELinux:  Registering netfilter hooks
SELinux:  Disabled at runtime.
SELinux:  Unregistering netfilter hooks
audit(1246291820.274:2): selinux=0 auid=4294967295 ses=4294967295
0
Ron MalmsteadInformation Services ManagerCommented:
Check this out this PDF below, and make sure you didn't miss anything.  Setting up elastix should be pretty straightforward.  You should have to "do" anything to get it listending for SIP, other than create devices/extensions and assign the box an IP address..

http://elastixconnection.com/downloads/elastix_without_tears.pdf
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

Ron MalmsteadInformation Services ManagerCommented:
To test your current setup, I would try using X-Lite from www.counterpath.com

http://www.counterpath.com/x-lite.html&active=4
0
crucialxAuthor Commented:
I've been following that exact document to get our Elastix server up and running, and it does not say anything about opening ports, so I'm not sure what the issue is!  
0
crucialxAuthor Commented:
xuserx2000, I've installed BOL SIPPhone (per the Elastix without Tears Guide) and when I try to connect it gives the error:

Log on failed! Server close the connection. (xxx@xxx.xxx.xxx.xxx)

Seems that it is not listening on those ports, however I can't seem to get it to work.  I've tried looking around the config files but can't figure out how to get them going.

If Elastix/Asterisk is working correctly, should I see the port open when using netstat?
0
feptiasChief DudeCommented:
Asterisk uses the standard SIP port and protocol - i.e. UDP port 5060. You are looking for a TCP port in a listening state so you are not going to see it. Try "netstat -lun" instead. Telnet is not suitable as a tool for testing UDP connectivity, only TCP.

Asterisk does not offer support for SIP over TCP or TLS until version 1.6. Even in that version, the comment in sip.conf says "Note that the TCP and TLS support for chan_sip is currently considered experimental." Also note that TCP is disabled by default in v1.6.

Can your phones not use UDP as the SIP transport protocol? Perhaps they are, but you have some other error.
0
Ron MalmsteadInformation Services ManagerCommented:
Feptias is correct.  You can't telnet to 5060....

Aside from that,... as I said before...Elastix is straightforward....Install it and connect a standard SIP phone.  It really is that simple.  So...maybe there is some other issue at play here.

Please try to use the free x-lite softphone on a windows machine....I'm not familiar with the one  listed in that pdf.  Make sure Elastix box has an IP address on your network, and try to connect to it with x-lite.

Can you give some more details on your setup ?...maybe some screenshots of Elastix screens might help.
0
crucialxAuthor Commented:
I ended up re-installing Elastix because I couldn't figure out what was causing the SIP phones not to be able to connect to Asterisk.  After the re-install, it appears to be working now!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ron MalmsteadInformation Services ManagerCommented:
...well since you were setting up a new box, thats what we probably should have suggested earlier on.
Would have been a quicker fix.

Second attempt was easy though.... no ?
It's designed to be so easy a caveman can do it.  :)
0
MathiauCommented:
good info here!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
IP Telephony

From novice to tech pro — start learning today.