Solved

RMAN-04002: ocipi failed, ORA--1

Posted on 2009-06-29
14
1,349 Views
Last Modified: 2012-05-07
Log into OS as rman account. When tried to connect and got RMAN-04002 error as below.
svr_name> rman
Recovery Manager: Release 10.2.0.3.0 - Production on Tue Jun 30 00:21:05 2009
Copyright (c) 1982, 2005, Oracle.  All rights reserved.
RMAN> connect target /
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-04002: ocipi failed, ORA--1

How to fix it?
Thanks!
0
Comment
Question by:luyan
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
14 Comments
 
LVL 3

Accepted Solution

by:
garysadler earned 500 total points
ID: 24742306
Try relinking the RMAN executable:

cd $ORACLE_HOME/rdbms/lib
make -f ins_rdbms.mk irman
0
 
LVL 40

Expert Comment

by:mrjoltcola
ID: 24742318
See Metalink article 780670.1
0
 
LVL 7

Expert Comment

by:meispisces
ID: 24742371
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:luyan
ID: 24745104
After I ran relink,
cd $ORACLE_HOME/rdbms/lib
make -f ins_rdbms.mk irman

still got the same error:
RMAN> connect target /
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-04002: ocipi failed, ORA--1
0
 
LVL 40

Expert Comment

by:mrjoltcola
ID: 24745213
Did something in your environment change?

You might try relinking all executables. (there is a script in ORACLE_HOME/bin called relink)

It should be as simple as "relink all"

Make sure to shutdown all Oracle programs before relinking.


If that fails, its time to open a SR with Oracle.
0
 

Author Comment

by:luyan
ID: 24747148
Do I need to shutdown all instances before I ran "relink all"?
Thanks!
0
 
LVL 40

Expert Comment

by:mrjoltcola
ID: 24747212
Yes.
0
 

Author Comment

by:luyan
ID: 24748029
Let me get downtime and try it. I will let you know. Thanks!
0
 

Author Comment

by:luyan
ID: 24751295
shut down instances and listener. Logged in as oracle account and ran
relink all
and
make -f ins_rdbms.mk irman.
Tried it again. Still got the same error.  
RMAN> connect target /
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-04002: ocipi failed, ORA--1

How to fix it?
Thanks!
0
 
LVL 40

Expert Comment

by:mrjoltcola
ID: 24751306
I think the only next step is to call Oracle / file a service request.

Something definitely amiss in your environment.
0
 
LVL 40

Expert Comment

by:mrjoltcola
ID: 24751339
Oracle classifies this error as "Not supposed to happen"

If you are unsupported, the only other option I can think of is to reinstall the Oracle software (the exact version that the database was created under).
0
 

Author Comment

by:luyan
ID: 24751734
It works now. But got error when register database.
RMAN> connect target /
connected to target database (not started)
RMAN> connect catalog /@rmansrv
connected to recovery catalog database
RMAN> register database;
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03002: failure of register command at 07/01/2009 01:26:31
RMAN-06403: could not obtain a fully authorized session
ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist
Linux-x86_64 Error: 2: No such file or directory

0
 
LVL 40

Expert Comment

by:mrjoltcola
ID: 24751794
Make sure ORACLE_SID is set correctly to your target prior to running RMAN

Also I've never seen the syntax you used above to connect to the catalog (connect catalog /@rmansrv) ??. I use the catalog owner which is usually named rman, see below.

export ORACLE_SID=ORA1
rman target / catalog rman/cat@CAT

0

Featured Post

Salesforce Made Easy to Use

On-screen guidance at the moment of need enables you & your employees to focus on the core, you can now boost your adoption rates swiftly and simply with one easy tool.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Oracle Listener Not Starting 11 66
upgrading Oracle 10g/ 11g / 11g R2 to Oracle 12c 25 89
Row_number in SQL 6 45
Oracle programming for starter 14 36
Why doesn't the Oracle optimizer use my index? Querying too much data Most Oracle developers know that an index is useful when you can use it to restrict your result set to a small number of the total rows in a table. So, the obvious side…
From implementing a password expiration date, to datatype conversions and file export options, these are some useful settings I've found in Jasper Server.
This video shows syntax for various backup options while discussing how the different basic backup types work.  It explains how to take full backups, incremental level 0 backups, incremental level 1 backups in both differential and cumulative mode a…
This video shows how to recover a database from a user managed backup

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question