Exchange 2003 not create email address for new user

Dear experts,

Have a problem with Exchange and don't know why and how to resolve.

We have an Exchange 2003 server. All were fine until a few days ago that it failed to create an email address for a newly added user.

Usually, Exchange will give an email address to a new user within, say minutes but this time it has taken almost 24 hours and still no email address been created. If I go into User Properties the Email Addresses tab is blank.

No change to any Email Policy whatsoever. The Recipient Policy is still there and I have already manually rebuild the Recipient Update Services, and ran the Mailbox Management Process.

Can any expert shed some light as where else I can look at please? I can probably create the email address manually but I want to understand why Exchange fail to do that in the first place in case there is something fundamentally wrong with it.

Thanks in advance.


LVL 23
ormerodrutterAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kieran_bCommented:
You are on the right path, it is the Recipient Update Service;

http://www.msexchange.org/articles/Troubleshooting-Exchange-Recipient-Update-Service-RUS.html
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ormerodrutterAuthor Commented:
The article from your link is a bit complicated.

Anyway the problem is resolved after I deleted the account and created it again. Within 10 minutes the email addresses populated.

For whatever reason it failed yesterday and I am pretty sure I did NOT untick the "create mailbox" icon.

Thanks for your help anyway.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.