Solved

Terminal Server Authentication fails

Posted on 2009-06-30
4
2,179 Views
Last Modified: 2013-11-21
Hello,

Ive setup a new TS farm with session broker enabled. One dedicated brokerserver, and four terminal servers.

Until today, i could login fine. I had some trouble when people were trying to login. They entered credentials, and logged in. However, after 3sec, the user gets prompted to login again. Event viewer said that might be caused by license trouble or an invalid certificate. After going through everything, and using a 3rd party certificate, it finally worked.

But now i faced another problem. When i log in to the session hostname, or directly to one of the terminal servers, i enter credentials and login. But then the following error occurs:

The remote computer requires that authentication be enabled to connect.
Remote computer: xxxx.xxxx.xxx
The connection cannot proceed because authentication is not enabled.

On the TS Configuration, Security layer is set to Negotiate, and Encryption level to Client Compatible. NLA is disabled, as there is only WinXP computers as clients (using XP SP3/RDP 6.1). Remote settings on the TS servers is set to accept connections from any version of RDP.

Ive tried changing lots of settings, but i still cant get it to work.
Any ideas?

0
Comment
Question by:jjugland
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 14

Expert Comment

by:theras2000
ID: 24744045
I had the same problem last week when I was learning/testing Session Broker in a VM test environment.  I also had XPsp3/RDP6.1.  I would love to know the answer.  One thing I did discover is that it worked fine from a Vista client.
0
 

Author Comment

by:jjugland
ID: 24744136
Year theras, i tried now with a Win7 computer, and that logged in fine! But noone else :X
0
 

Accepted Solution

by:
jjugland earned 0 total points
ID: 25012760
No solution found for this :(
0
 

Expert Comment

by:sahosupport
ID: 33754925
Resolution:-

In the TS Configuration, >> RDP-Tcp Properties >> change the Security Layer to
"Negotiate"
Recycle the TS Gateway service.
0

Featured Post

Transaction Monitoring Vs. Real User Monitoring

Synthetic Transaction Monitoring Vs. Real User Monitoring: When To Use Each Approach? In this article, we will discuss two major monitoring approaches: Synthetic Transaction and Real User Monitoring.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For anyone that has accidentally used newSID with Server 2008 R2 (like I did) and hasn't been able to get the server running again because you were unlucky (as I was) and had no backups - I was able to get things working by doing a Registry Hive rec…
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…

687 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question