Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

New .NET application won't run in IIS

Posted on 2009-06-30
4
Medium Priority
?
318 Views
Last Modified: 2012-05-07
Hi,

I have a C# web application. It runs perfectly on the dev system. I published it and copied it to the live server. I manually created a new virtual directory. I set the .NET version to be .NET 2.0. I pointed it to the location of my web app and it gives me a 404 error despite being able to see the files in IIS. If I right mouse click and do Browse I get a 404. I manually created an html file in there called index.html and in there I did a redirect to default.aspx which is in the same folder. I set index.html to be the first file name to look for when no file name is given in the request. The html file loads and after 5 seconds redirects but gives me a 404 error. It is as if IIS can't see the .NET application in the folder. Any ideas welcome. Please ask for more info if needed.

Cheers,

Lee
0
Comment
Question by:Lee Savidge
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 4

Accepted Solution

by:
madhubk earned 2000 total points
ID: 24747617
Greetings,

Are you able to access the IIS Help pages? Normally these start with a IISStart.aspx or so... Not sure of the exact file name.

Under the applications that you have, are you permitting ASP to be executed? similarly is there a ASP.Net execute permission?

Post your findings...

~m at your service
0
 
LVL 15

Expert Comment

by:Tray896
ID: 24747780
You'll get a 404 if the ASP.NET web extension isn't allowed.  To fix this, open up IIS and click on the Web Service Extensions in the left panel.  Verify that ASP.NET is set to Allowed.  Once that is allowed you should be able to browse .net content with no issues.
0
 
LVL 25

Author Closing Comment

by:Lee Savidge
ID: 31598311
LOL. I don't know how many times I've deployed .NET applications... I forgot to change ASP.NET from Prohibited to Allowed in the IIS Web Service Extensions.

I amaze myself sometimes... Thanks for pointing it out :)

Lee
0
 
LVL 25

Author Comment

by:Lee Savidge
ID: 24747797
Sorry Tray896. I awarded the points as you posted but FYI you were dead on the nail.

Thanks anyway.

Lee
0

Featured Post

Will your db performance match your db growth?

In Percona’s white paper “Performance at Scale: Keeping Your Database on Its Toes,” we take a high-level approach to what you need to think about when planning for database scalability.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

What is an ISAPI filter?   •      It's an assembly (.dll file) that can add or change the way IIS works.   •      They can be enabled globally for your web server or on a site-by-site basis.   When the IIS server receives a request, enabling the ISAPI fi…
As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.
Suggested Courses

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question