Solved

to help prevent malicious code from running one or more objects in this form were not loaded

Posted on 2009-06-30
3
3,723 Views
Last Modified: 2012-05-07
Hello,

Some years ago, I developped a custom form which I published in My Organizational Forms Library. The form was designed in Outlook 2000 and I used the Excel object (msowc.dll). The form was still working in Outlook 2003 as long as the msowc.dll was registered.

When I upgraded to Outlook 2003 SP3, I had an error once I closed the form and this was fixed by installing the hotfix 935411.

Now I am not able to open the form. I got the message: "to help prevent malicious code from running one or more objects in this form were not loaded"

I don't know what happened. I have other users with the same Outlook version and it is working for them

Thanks for your help
S.
0
Comment
Question by:slimard
  • 2
3 Comments
 
LVL 11

Accepted Solution

by:
techzter earned 500 total points
ID: 24744712
Here are two options you can try. The first one covers a corrupted cache that might cause the form to fail. The second is a registry entry to specifically allow the form to run.

First:
http://www.pcreview.co.uk/forums/thread-3370960-2.php
Have you done any customizations to the form? The issue might be a corupted
form cache. You could try to clear your forms cache:

goto Tools->Options

Click on Advance Options button
Click on Custom Forms button
Click on Manage Forms button

Click the clear cache button.

Close all the opened dialogs and restart outlook.



Second:
http://www.outlookcode.com/article.aspx?id=67
The ideal solution for this issue is to avoid one-off forms completely. If you must use a one-off  and you are using Outlook 2003, you can use a registry entry or policy to control the behavior. (This option is not availble in Outlook 2002 SP3). To use a registry entry, add a DWORD value named AllowActiveXOneOffForms to the HKCU\Software\Microsoft\Office\11.0\Outlook\Security value and set it to one of these values:\

    0               Load only the frm20.dll controls, the Outlook View Control, Outlook Recipient Control, and the docsite (message body) control
    1               Allow only controls marked as "safe for initialization" to load
    2               Allow all ActiveX controls to load
0
 

Author Comment

by:slimard
ID: 24744910
Basically, I have tried both possible solutions before posting but it did not help. I have two other custom forms where I used the Excel object and the two forms are not working also.
0
 
LVL 11

Expert Comment

by:techzter
ID: 24745018
Sorry that it wasn't more help. You mentioned that it is working on other machines with the same version of office without issue. Perhaps try to remove and reinstall office to see if the issue clears? I don't work with custom forms so perhaps someone that is more familiar with them may be able to come along and shed some better light on the issue for you.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
When you have clients or friends from around the world, it becomes a challenge to arrange a meeting or effectively manage your time. This is where Outlook's capability to show 2 time zones in one calendar comes in handy.
Get people started with the process of using Access VBA to control Outlook using automation, Microsoft Access can control other applications. An example is the ability to programmatically talk to Microsoft Outlook. Using automation, an Access applic…
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question