• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 538
  • Last Modified:

RedHat 4 NTP Server with Clients No External NTP Source

Hi Experts ---

I am in a lab environment and need to establish a temporary NTP server to run some tests.  The server will be on a machine running RedHat 4.  How do I set-up the server ( what does the conf file look like) and how do I set-up the NTP clients?  
0
GDC4S1
Asked:
GDC4S1
  • 4
1 Solution
 
Kerem ERSOYPresidentCommented:
Hi,

You can find the configutarion files under /etc/ntp.conf and sstll others under /etc/ntp. If you're missing these files then probably you're missing the ntp installation files (this is ery unlikley becasue RHEL4 installs this packaes as a mandatory extension during setup)

To check if it is active you can use this command:

chkconfig --list ntpd

It should respond with:
ntpd            0:off   1:off   2:off   3:on    4:off   5:on    6:off

If it is all off you need to enable it for start durinf startup like that:
chkconfig ntpd on

Then the above command should return on fer level 3 and 5.

Cheers,
K.
0
 
Kerem ERSOYPresidentCommented:
If hovewer you feel that you're missing the package you can install it using the command:

up2date ntpd

or

yum install ntpd.
0
 
Kerem ERSOYPresidentCommented:
To start and stop the service you'd use the command

service ntpd start | stop | restart

0
 
GDC4S1Author Commented:
KeremE ---

I have ntpd on my system.  The question is what goes in the conf file.  For example, I don't have an external timing source which is in the conf file.  So, do I just keep that and it times out or do I comment it out?
0
 
Kerem ERSOYPresidentCommented:
oh ok. Your intial  comment also told that. If all you have is a NTP server and you have no internet connection.  If this is the case you needto find the server lines in your /etc/ntp.conf

server 127.127.1.0
fudge   127.127.1.0 stratum 10

Just leave these lines. then you'll have lines similar to these:

server 0.pool.ntp.org
server 1.pool.ntp.org


Comment each line bebings with server statement. Not you're good to go.

you can usee chkconfig to enable sntp set to start on reboot using:

chkconfig --list ntpd  

will display if it is set to run.. If it is off for all levels then it won2t run when the system reboots. to change this use the command such as this:

chkconfig ntpd  on

Then the list command must show that it is on for levels 3 and 5

f you want to start the service manually can use service command

service ntpd start

service ntpd stop

service ntpd restart





0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now