Solved

Forward not working in Bind

Posted on 2009-06-30
5
1,393 Views
Last Modified: 2013-12-23
We are not able to forward requeses to the servers listed:

zone "xxx.com" IN {
       type forward;
       forwarders { xxx.xxx.104.13; xxx.xxx.104.40; };
};
0
Comment
Question by:axl13
  • 3
  • 2
5 Comments
 
LVL 4

Expert Comment

by:Adraenyse
ID: 24747679
Can you post the Options portion of your configuration, and what leads you to believe that it is not working?
0
 

Author Comment

by:axl13
ID: 24747711
options {
#
        directory       "/var/named";
        pid-file        "/var/named/named.pid";
        allow-transfer { xxx.xxx/16; };
        transfer-format one-answer;
        };
logging {
        channel my_file {
                file "/var/named/dns.log";
                severity dynamic;
                print-category yes;
                print-severity yes;
                print-time yes;
                };
#       category default { my_file; };
        category update { my_file; };
        category notify { my_file; };
        category xfer-in { my_file; };
        category xfer-out { my_file; };
#       category security { my_file; };
#       category queries { my_file; };
        };

nslookup turns up server cant find domain: Non-existent domain
0
 

Author Comment

by:axl13
ID: 24868971
Still not able to get FORWARD to work...
0
 
LVL 4

Expert Comment

by:Adraenyse
ID: 24869656
You have no forwarders in your options. Do you have a root hints zone? If not, there is no where for bind to look up any information.


In your options section you need a forwarders statement such as:

forwarders      { 208.67.222.222; 208.67.220.220; };

(These are the OpenDNS servers. I prefer them over any of my ISP servers as they are more reliable and answer faster. http://www.opendns.com/)
Not directly related to your question, but I would recommend also having an allow-recursion statement in your options section for your local subnets or bind will not fully resolve queries for your local machines.

allow-recursion { 127.0.0.1; xx.xx.xx.xx/16; };

Using the statement forward first in the options section will tell bind to try your forwarders first, and if unsucessful, then proceed to query the root zone servers for an answer.

forward first;

If you do not have a root hints zone, this is how you create one

- Connect to ftp.internic.net as anonymous and download domain/named.root- Place named.root in your /var/named directory and chown it named.named and chmod it to 444
- Add the following zone statement to named.conf (outside of the options statement of course)

zone "." { type hint; file "named.root"; };

Hope that helps
Adrae
0
 

Accepted Solution

by:
axl13 earned 0 total points
ID: 25854028
We could not get the forwarding to work, so we had the users seconday the zone
0

Featured Post

Give your grad a cloud of their own!

With up to 8TB of storage, give your favorite graduate their own personal cloud to centralize all their photos, videos and music in one safe place. They can save, sync and share all their stuff, and automatic photo backup helps free up space on their smartphone and tablet.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Resolve DNS query failed errors for Exchange
For many of us, the  holiday season kindles the natural urge to give back to our friends, family members and communities. While it's easy for friends to notice the impact of such deeds, understanding the contributions of businesses and enterprises i…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

896 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now