Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Server 2003 Authentication issues

Posted on 2009-06-30
3
Medium Priority
?
246 Views
Last Modified: 2012-05-07
I setup a new website on my server. I am using plesk with server 2003. I installed mssql 2008 and put up a database. I copied the contents of my website over and the page loads and logs into the site. The problem is it keeps popping up and asking me for the user name and password. It pops up like a windows password prompt. I have looked through everything I know to do.

How do I get this working? The page won't load properly because of this.
0
Comment
Question by:kingent85
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 15

Accepted Solution

by:
Tray896 earned 2000 total points
ID: 24748120
Does it prompt you when you try to hit it from another computer as well, or only when you load the browser directly from the server?  If it only happens from the server then it may be caused by a built in security mechanism.  I wrote an article about it here:  http://www.experts-exchange.com/articles/Software/Server_Software/Web_Servers/Microsoft_IIS/Fix-401-1-Error-when-browsing-a-website-using-integrated-authentication-directly-from-the-server.html

If it happens from anywhere, then you might need to add it as a trusted site in your browser.  Or you could actually have a permissions issue which I would recommend using Filemon to troubleshoot:
http://technet.microsoft.com/en-us/sysinternals/bb896642.aspx
0
 
LVL 6

Expert Comment

by:guydemarco
ID: 24748155
Did you install the Plesk Power pack? M$SQL support is enabled in Power Pack, but not in the default Plesk license key. Once installed, you can configure the Database Server by surfing to Plesk > Server > Databases page.

You can also use a machine account for the database instead of a user account. Make sure you set the machine account up with the appropriate access to the database instance.
0
 
LVL 6

Expert Comment

by:brasslan
ID: 24748163
I would check in IIS.  Inside the web site properties, under the Directory Security tab, edit the Authentication and Access Control.  Verify that enable anonymous access is checked.

Also, on the folder that actually holds the web site files, you should check the NTFS security permissions to see if the anonymous IUSR has access to those files.
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…
Is your data getting by on basic protection measures? In today’s climate of debilitating malware and ransomware—like WannaCry—that may not be enough. You need to establish more than basics, like a recovery plan that protects both data and endpoints.…
Suggested Courses

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question